Trabalho de algoritmo

Disponível somente no TrabalhosFeitos
  • Páginas : 6 (1306 palavras )
  • Download(s) : 0
  • Publicado : 4 de abril de 2013
Ler documento completo
Amostra do texto
Engenharia Civil
Disciplina: Algoritmos e Técnicas de Programação I
2º Semetre/2012 - Turma: 2º período
Alunos: Denilson Gomes, Afonso Lima, Julio Cezar Carvalho, Luciano Silva e Alexandre




























1ª Questão: O Tribunal Regional Eleitoral adota os seguintes critérios para os eleitores: os que possuem idades abaixo de 16 anos não pode votar.Pessoas com idades de 16 e 17 anos ficam opcionais votar. Aqueles com idades a partir de 18 até aos 65 anos é eleitor. Depois dos 65 anos fica opcional votar. Crie um programa para pedir o nome e a idade de 180 cidadãos e para cada um deles e escreva a mensagem correspondente de acordo com os critérios do TRE.
- “NÃO PODE VOTAR!”
- “É ELEITOR!”
- “OPCIONAL!”

RESP:

Início PRGVT
declare Cliteral
I,A numérico
PARA A DE 1 ATÉ 180 FAÇA
escreva “ Nome:” leia C
escreva “ Idade:” leia I
SE (I >= 18) E (I =65)
ENTÃO
escreva “É eleitor“
SENÃO
SE (I =15) E (I =18)
ENTÃO
escreva “Opcional”
SENÃO
escreva “Não Pode Votar”
FIM SE
FIM SE
FIM PARA
FIM PRGVT

2ª Questão: Num certo dia é necessário identificar a temperatura em 30 Municípios brasileiros. Fazer umprograma para solicitar o CEP e a temperatura em graus Centígrados de cada Município e para cada um deles calcular e informar a temperatura correspondente em Farenheit, aplicando a fórmula a seguir. Ao final informar quantos Municípios obteve temperatura acima de 67º Farenheit.

| |
|C ( 5 ( F - 32) |
|9|


RESP:

Início PRGC
declare RES literal
CEP, MU, T, FAR numérico
RES("N"
ENQUANTO RES = "S" FAÇA
escreva "Digite o CEP: " leia CEP
escreva "Digite a Temperatura: " leia T
FAR( (T*1.8)+ 32
escreva "Temperatura em Farenheit: ", FAR
SE FAR > 67
ENTÃO
MU< MU + 1
escreva " Para encerrar digite‘S’ ...” leia RES
FIM SE


FIM ENQUANTO
escreva "Municípios acima de 67º Farenheit: ",MU
FIM PRGC


3ª Questão: Fazer um programa para solicitar o número da chamada e as duas notas (VC1 e VC2) de 67 alunos da turma T311. Para cada aluno calcular e informar seu total (soma da VC1 mais a VC2) e a sua situação.
Obs.: Total abaixo de 7.0 = “REPROVADO”;
Total maior ou iguala 14.0 = “APROVADO”
Demais casos = “PROVA FINAL – VE”

RESP:

Início PRGVC1
declare NUMCH, I, VC1, VC2, TOT numérico
PARA I DE 1 ATÉ 67 FAÇA
  escreva "Número da Chamada: " leia NUMCH
  escreval " 1º nota: " leia VC1
  escreval " 2º nota: " leia VC2
 TOT( VC1 + VC2
escreva “Total das Notas ( “, TOT
  SE TOT>= 14.0
ENTÃO
      escreva "Aprovado"
  SENÃO
   SE TOT< 7.0ENTÃO
    escreva "Reprovado"
   SENÃO
   escreva "Prova final "
 FIM SE
FIM SE
FIM PARA
FIM PRGVC

4ª Questão: Faça um programa para solicitar o nome, o sexo e o salário-base de n empregados. Para cada um deles calcular e informar o desconto (5% sobre o salário-base) e o salário líquido. Obs.:  ( Considere que só serão digitados “M” ou “F” para sexo.

RESP:

Início PRGSAL
declare NO,SX, RES literal
SALB, DES, SALL numérico
REPITA
escreva “Informe o Nome: “ leia NO
escreva “Informe o Sexo (M ou F): “ leia SX
escreva “Informe o Salário Base: “ leia SALB
DES( SALB*0.05
SALL( SALB-DES
escreva “Valor do Desconto ( “, DES
escreva “Sálario Líquido ( “, SALL
escreva “ Para Encerrar Digite ‘S’ ...”, leia RES
ATÉ RES=”S”
FIM PRGSAL



5ª Questão: Numafábrica trabalham 178 operários divididos em três classes:

A – os que fazem até 30 peças por mês;
B – os que fazem de 31 a 35 peças por mês;
C – os que fazem mais de 35 peças por mês.

A classe “A” recebe salário mínimo. A classe “B” recebe salário mínimo e mais 3% do salário-mínimo por peça, acima das 30 iniciais. A classe “C” recebe salário-mínimo e mais 5% do salário-mínimo por peça...
tracking img