trabalho de algoritmo

Disponível somente no TrabalhosFeitos
  • Páginas : 7 (1740 palavras )
  • Download(s) : 0
  • Publicado : 4 de outubro de 2014
Ler documento completo
Amostra do texto
Estrutura Sequencial
1) O que é lógica?
Logica seria a “correção do pensamento”, que determina quais opções são validas e quais não são,
analisando as formas e leis do pensamento, ou seja, logica seria um raciocionio valido.
2) De três exemplos de sequencias lógicas.
1. Receita de miojo – Coloque agua para ferver > abra o miojo > coloque na agua fervendo...
2. Entrar no carro - Pegue achave > abra a porta > entre > feche a porta
3. Saque em caixa eletronico – Coloque o cartao > Digite a senha > Va na opção saque...
3) Quais são os tipos de fluxogramas mais utilizados?
Diagrama de blocos, fluxograma de processo simples, fluxograma Funcional, Fluxograma Vertical,
Fluxograma ANSI.
4) Desenvolva fluxogramas no padrão ANSI para os seguintes problemas:
a) Leia 4 números, calcule eapresente a soma dos quatro números, a subtração do segundo pelo
primeiro, a multiplicação do terceiro pelo quarto e a divisão da soma total por 4.

b) Calculo da área de um retângulo.

c) Leia 3 notas de um aluno, calcule e apresente a média final.

d) Leia altura e peso e calcule o índice de massa corpórea (IMC). “IMC = Divisão do peso pela
altura ao quadrado.”

5) Analise os seguintesblocos de código dos algoritmos abaixo e diga o que será impresso ao serem
executados:
a) A=20
1. A := 20

2. B := 10
3. escreva (B)
4. B : = A
5. escreva (A)
b) A=14
1. A : = 10
2. B : = Α + 1
3. A : = Β + 1
4. B : = A + 1
5. escreva (A)
6. A := Β + 1
7. escreva (A)
c) x=2,5 y=2,5 elefante=7,75
1. x := (4/2)+(2/4)
2. y := 4/2+2/4
3. elefante := 56/32+6
4. escreval (x)
5.escreval (y)
6. escreval (elefante)
6) Marque (V) valido ou (I) invalido para os nomes de variáveis segundo a regra vista em aula.
“Justifique sua resposta”
(V) A = Não contradiz nenhuma regra
(F) 1º Num = Começa com numero
(F) 1n = Começa com numero
(V) casa = Não contradiz nenhuma regra
(F) Nº1 = Contem caractere especial
(F) 1% = Contem caractere especial

(V) n1 = Não contradiznenhuma regra
(F) base nova = Invalido pois a espaço
(F) leia = É uma palavra reservada
(V) casa_velha = Não contradiz nenhuma regra
(F) inteiro = É uma palavra reservada
(F) algoritmo = É uma palavra reservada

7) Faça um algoritmo em fluxograma e pseudocódigo que leia três números informados pelo
usuário, calcule e apresente a média ponderada, sabe-se que os pesos são respectivamente: 1, 2, e3;

variaveis:
n1,n2,n3,p1,p2,p3,mp:real
inicio
p1:=1
p2:=2
p3:=3
escreva ("1ª nota -->")
leia (n1)
escreva ("2ª nota -->")
leia (n2)
escreva ("3ª nota -->")
leia (n3)
mp:=((n1*p1)+(n2*p2)+(n3*p3))/(p1+p2+p3)

escreva ("Media ponderada -->", mp)
fimalgoritmo
8) Escreva um algoritmo em fluxograma e pseudocódigo para ler o salário mensal e o percentual de
reajuste. Calcular eescrever o valor do novo salário.

variaveis:
salario,preajuste,novosalario:real
inicio
escreva ("Salario --> ")
leia (salario)
escreva ("percentual de reajuste -->")
leia (preajuste)
novosalario:=((salario*preajuste)/100)+salario
escreva ("Novo salario é -->", novosalario)
fimalgoritmo
9) Escreva um algoritmo em fluxograma e pseudocódigo que armazene o valor 28 em uma
variável “A” e ovalor 16 em uma variável “B”. A seguir (utilizando apenas atribuições entre
variáveis) troque os seus conteúdos fazendo com que o valor que está em “A” passe para
“B” e vice-versa. Ao final escrever os valores que ficaram armazenados nas variáveis.

variaveis:
A,B,C:inteiro
inicio
A:=28
B:=16
C:=A
A:=B
B:=C
escreva("A -->",A,"B -->",B,)
fimalgoritmo
10) Faça um algoritmo emfluxograma e pseudocódigo que leia o horário de entrada (hora, minuto)
e o horário de saída (hora, minuto) de uma aula e informe quanto tempo ela dura, no formato hora :
minuto.

var
hora1, minuto1, hora2, minuto2: inteiro
inicio
repita
escreval ("Digite a Hora de entrada")
leia (hora1)
se (hora1 >= 24) entao
escreval ("Hora invalida!")
fimse
ate (hora1 < 24)
repita
escreval ("Digite a...
tracking img