Ti online

Disponível somente no TrabalhosFeitos
  • Páginas : 3 (572 palavras )
  • Download(s) : 0
  • Publicado : 19 de novembro de 2011
Ler documento completo
Amostra do texto
Construção de algoritmos
Alunos/RA: Thiago / 3233551562 - Rogério / 3233524717
Diego /3226024129 - Jonatan 3218519621

Relatório do projeto
ETAPA nº1
Passo 1
O primeiro algoritmo temcomo objetivo ler um valor que o usuário deseja converter de real para dólar. Com apenas uma variável declarada, do tipo real. O programa lê o valor desejado e armazena na variável “valor” e logo emseguida apresenta com valor convertido em dólar.

ETAPA nº2
Passo 1
Nessa etapa do projeto o usuário além de escolher o valor da moeda, ele também poderá escolher de qual moeda e para moeda eledeseja fazer a conversão. Nesse caso foi usado além das instruções básicas como escreva e leia, foi usada a instrução escolha que fará com que a lógica estabelecida seja mais simples e coerente. Foramdeclaradas apenas três variáveis: “valor” do tipo real – variável que receberá o valor da moeda, “base” do tipo caracter – variável que armazenará a primeira escolha e convert também do tipocaráter- variável que armazenará a segunda escolha.

APS
Etapa º 1
Passo 1
algoritmo "Conversão"
var
valor: real
inicio
escreva("Digite o valor que deseja converter: R$ ")leia(valor)
escreval("RS",valor," representa US$",valor*1.88)
fimalgoritmo
Passo 2
algoritmo "Conversão"
var
valor: real
inicio
escreva("Digite o valor que deseja converter:RS$ ")
leia(valor)
escreval("RS",valor," representa US$",valor*1.88)
escreval("RS",valor," representa CDN$",valor*1.77)
escreval("RS",valor," representa Euros",valor*2.49)fimalgoritmo

Passo 3
algoritmo "Conversão"
var
valor: real
convert: caracter
inicio
escreva("Digite o valor que deseja converter: RS$ ")
leia(valor)escreval("Para qual a moeda deseja fazer a conversão?")
escreval("(a)dolar americano")
escreval("(c)dolar canadense")
escreval("(e)euro")
leia(convert)
escolha(convert)...
tracking img