Tecnologia

Disponível somente no TrabalhosFeitos
  • Páginas : 3 (530 palavras )
  • Download(s) : 0
  • Publicado : 20 de setembro de 2012
Ler documento completo
Amostra do texto
opa, é um programa simples você faz um loop assim:
Enquanto voto != "fim" faça
Escreva("Digite seu voto);
leia(voto);
Escolha (voto):
        caso "João"     : ++cont_joao;
       caso "Maria"   : ++cont_maria;
        .
        .
        caso contrario: Escreva("Digite um voto valido");
Fim_escolha
.
.  //Bom você tbm tem q pensar no q fazer aki neh

algoritmo "UrnaEletrônica"
// Função : Eleição para Síndico
// Autor :
// Data : 06/6/2008
// Seção de Declarações
var
candidato,vencedor:caracter
j,c,m,b,n:inteiro

inicio
// Seção de Comandosjoao,carlos,maria,nulo,branco
leia(candidato)
enquanto candidato <> "fim" faca
escolha candidato
caso "Joao"
j <- j + 1
caso "Carlos"
c <- c + 1
caso "Maria"
m <- m + 1
outrocaso
se(candidato = "") entao
b <- b + 1
senao
n <- n + 1
fimse
fimescolha
leia(candidato)
fimenquanto

--- Falta concluir ----

Brother , uma ajuda ae. Estou indo no caminho certo(conclusão) ???
Aguardo resposta.

Algoritmo eleição em dev c++

Preciso fazer o seguinte algoritmo, mas não consegui...

Em uma eleição presidencial, existem quatro candidatos. Os votos são informadosatravés do códigos a seguir:

1 = Dilma Rousseff

2 = José Serra

3 = Ciro Gomes

4 = Marina Silva

5 = voto em branco.

Outros casos = voto nulo;

Faça um programa que calcule eimprima:

Total de votos para cada candidato.
Total de votos nulos;
Total de votos em branco;
Porcentagem de cada presidente em relação ao total de votos.
Porcentagem de votos nulos sobre ototal de votos;
Porcentagem de votos em branco sobre o total de votos.
Qual candidato foi vencedor, se houver 2º Turno, quais são os dois concorrentes.

Para finalizar o conjunto de votos, tem-se ovalor zero

1.Total de votos para cada candidato. :
--coloque um cont++ para cada voto pra cada candidato.
2.Total de votos nulos;
--mesma coisa com contador..
3.Total de votos em branco;...
tracking img