Sistema

Disponível somente no TrabalhosFeitos
  • Páginas : 3 (510 palavras )
  • Download(s) : 0
  • Publicado : 20 de setembro de 2012
Ler documento completo
Amostra do texto
Henrique de Jesus. RA: 5825170325
Algoritmo: horóscopo.

var
dia, mes: inteiro
inicio
// Seção de Comandos
escreval ("+++Insira a data do seu aniversario para descobrir o seu signo+++")escreval ("--dia--")
leia (dia)
escreval ("--mes--")
leia (mes)
se (dia >=21) e (dia <=31) e (mes =3) ou (dia <=20) e (mes =4) entao
escreval ("Seu signo é Áries!")
senao
se (dia >=21)e (dia <=30) e (mes =4) ou (dia <=20) e (mes =5) entao
escreval ("Seu signo é Touro!")
senao
se (dia >=21) e (dia <=31) e (mes =5) ou (dia <=20) e (mes =6) entao
escreval ("Seusigno é Gemêos!")
senao
se (dia >=21) e (dia <=30) e (mes =6) ou (dia <=21) e (mes =7) entao
escreval ("Seu signo é Câncer!")
senao
se (dia >= 22) e (dia <=31) e (mes =7) ou (dia<=22) e (mes =8) entao
escreval ("Seu signo é Leão!")
senao
se (dia >=23) e (dia <=31) e (mes =8) ou (dia <=22) e (mes =9) entao
escreval ("Seu signo é Virgem!")
senao
se (dia >= 23) e(dia <=30) e (mes =9) ou (dia <=22) e (mes =10) entao
escreval ("Seu signo é Libra!")
senao
se (dia >=23) e (dia <=31) e (mes =10) ou (dia <=21) e (mes =11) entao
escreval ("Seusigno é Escorpião!")
senao
se (dia >=22) e (dia <=31) e (mes =11) ou (dia <= 21) e (mes =12) entao
escreval ("Seu signo é Sagitário!")
senao
se (dia >=22) e (dia <=31) e (mes =12) ou(dia <=20) e (mes =1) entao
escreval ("Seu signo é Capricornio!")
senao
se (dia >=21) e (dia <=31) e (mes =1) ou (dia <=19) e (mes =2) entao
escreval ("Seu signo é Aquário!")
senaose (dia >=20) e (dia <=28) e (mes =2) ou (dia <=20) e (mes =3) entao
escreval ("Seu signo é Peixes!")
fimse
fimse
fimse
fimse
fimse
fimse
fimse
fimse
fimse
fimse
fimse
fimse
se(dia >28) e (mes =2) entao
escreval ("o mes de fevereiro possui apenas 28 dias, insira uma data valida!!!")
fimse
se (dia >31) e (mes =1) entao
escreval ("dia invalido")
fimse
se (dia...
tracking img