Algoritmos visualg

Disponível somente no TrabalhosFeitos
  • Páginas : 5 (1057 palavras )
  • Download(s) : 0
  • Publicado : 14 de dezembro de 2012
Ler documento completo
Amostra do texto
1) Faça um algoritmo que pergunte ao usuário se ele deseja visualizar números pares ou números impares. Em seguida exiba todos os números pares ou números ímpares entre 0 e 100, de acordo com a opção escolhida pelo usuário. O algoritmo deve continuar até que o usuário “não desejar mais continuar executando”.

algoritmo "mostrar par ou ímpar"
var
n:inteiro
conf, num:caracter
inicio
//Seção de Comandos
conf<-"s"
enquanto conf="s" faca
escreval("Você deseja visualizar números pares ou números impares? par/impar")
leia(num)
se num="par" entao
para n de 0 ate 100 passo 2 faca
escreval(n)
fimpara
senao
se num="impar" entao
para n de 1 ate 99 passo 2 faca
escreval(n)
fimpara
fimsefimse
escreval("Deseja continuar? s/n")
leia(conf)
fimenquanto
fimalgoritmo

2) Faça um algoritmo que leia 10 valores inteiros e no final, informe quantos são menores do que 10, em seguida mostre a quantidade e o somatório dos valores que forem maiores do que 10. O algoritmo deve continuar até que o usuário “não desejar mais continuar executando”.

algoritmo "questão 2"
varn,CON,contmaior,contmenor,soma:inteiro
conf:caracter
inicio
// Seção de Comandos
conf<-"s"
enquanto conf="s" faca
CON<-0
contmaior<-0
soma<-0
contmenor<-0
escreval("Informe 10 números: ")
enquanto CON<10 faca
leia(n)
se n>10 entao
contmaior<-contmaior+1
soma<-soma+n
senao
se n<10 entaocontmenor<-contmenor+1
fimse
fimse
CON<-CON+1
fimenquanto
escreval("Quantidade de números menores que 10: ",contmenor)
escreval("Quantidade de números maiores que 10: ",contmaior)
escreval("Somatório dos números maiores que 10: ",soma)
escreval("Deseja continuar? s/n")
leia(conf)
fimenquanto
fimalgoritmo

3) Faça um algoritmoque exiba todos os números múltiplos de 10, entre 1000 e 500.

algoritmo "Múltiplos de 10"
var
mult:inteiro
inicio
// Seção de Comandos
escreval ("Múltiplos de 10 entre 1000 e 500:")
para mult de 1000 ate 500 passo -10 faca
escreval(mult)
fimpara
fimalgoritmo

4) Faça um algoritmo que leia um número e informe se o valor do número digitado é par ou impar. O algoritmo devecontinuar até que o usuário “não desejar mais continuar executando”.

algoritmo "Par ou ímpar"
var
n,CON:inteiro
conf:caracter
inicio
// Seção de Comandos
CON<-0
conf<-"s"
enquanto conf="s" faca
escreval("Informe um número: ")
leia(n)
se (n mod 2)=0 entao
escreval("O número é par.")
senao
escreval("O número é ímpar.")
fimse
escreval("Deseja continuar?s/n")
leia(conf)
fimenquanto
fimalgoritmo

5) Faça um algoritmo que leia três números, e mostre a soma e média aritmética entre os três números informados pelo usuário. O algoritmo deve continuar até que o usuário “não desejar mais continuar executando”.

algoritmo "questão 5"
var
CON:inteiro
MA,n,soma:real
conf:caracter
inicio
// Seção de Comandos
conf<-"s"
enquantoconf="s" faca
CON<-0
soma<-0
escreval("Informe 3 números: ")
enquanto CON<3 faca
leia(n)
soma<-soma+n
CON<-CON+1
fimenquanto
MA<-soma/3
escreval("A soma dos números é: ",soma)
escreval("A média aritmética dos números é: ",MA)
escreval("Deseja continuar? s/n")
leia(conf)
fimenquanto
fimalgoritmo

6) Faça um algoritmoque exiba na tela a tabuada completa (de 1x1=1 até 10x10=100). Capriche para que ela saia igual a que você usava na escola.

algoritmo "tabuada"
var
n,i:inteiro
inicio
// Seção de Comandos
n<-1
para n de 1 ate 10 faca
escreval("Tabuada do ",n," :")
i<-1
para i de 1 ate 10 faca
escreval(n," x",i," = ",n*i)
i<-i+1
fimpara
n<-n+1
fimpara...
tracking img