Algoritmo

Disponível somente no TrabalhosFeitos
  • Páginas : 2 (362 palavras )
  • Download(s) : 0
  • Publicado : 14 de novembro de 2011
Ler documento completo
Amostra do texto
algoritmo "Exemplo de Projeto Informatica"

var
Repetir, Comodo, Continua: Caracter
Piso:Inteiro
Comprimento, Largura, Area, AreaCaixa: Real
QuantidadeCaixa, ValorCaixa, ValorTotal:Real

inicio
repita
Continua := "S"
LimpaTela()
// INICIO DOS COMANDOS
Escreval("*****************************")
Escreval("Sistema para Cálculo de Pisos")Escreval()

// Inicio do Bloco da Escolha do Tipo do Piso
Escreval("Informe o Tipo de Piso a ser aplicado:")
Escreval("1 - 45x45 - Caixa: R$ 100")
Escreval("2 - 40x40 -Caixa: R$ 200")
Escreval("3 - 100x100 - Caixa: R$ 150")
Escreval("4 - 33x33 - Caixa: R$ 250")
Escreval("5 - 80x80 - Caixa: R$ 300")
Escreva("Tipo do Piso: ")
Leia(Piso)// Final do Bloco da Escolha do Tipo do Piso

// Inicio do Bloco da Escolha do Tipo do Comodo
Escreval()
Escreval("Informe o Tipo do Comodo onde o piso será aplicado:")Escreval("B - Banheiro")
Escreval("C - Cozinha")
Escreval("Q - Quarto")
Escreval("S - Sala")
Escreval("G - Garagem")
Escreva("Tipo do Comodo: ")
Leia(Comodo)Escreval()
// Final do Bloco da Escolha do Tipo do Comodo

// Inicio do Teste do Piso x Comodo
se (Piso = 1) E (Comodo = "B") entao
Continua := "N"
Escreval("Escolhaincorreta!")
Escreval("O Piso escolhido não é indicado para este comodo.")
fimse

se (Piso = 2) E (Comodo = "C") entao
Continua := "N"
Escreval("Escolha incorreta!")Escreval("O Piso escolhido não é indicado para este comodo.")
fimse

se (Piso = 3) E ((Comodo = "S") OU (Comodo = "Q")) entao
Continua := "N"
Escreval("Escolhaincorreta!")
Escreval("O Piso escolhido não é indicado para este comodo.")
fimse
// Final do Teste do Piso x Comodo

Escolha Piso
Caso 1
AreaCaixa := 2.025...
tracking img