Algoritmo vetor/matriz

Disponível somente no TrabalhosFeitos
  • Páginas : 5 (1014 palavras )
  • Download(s) : 0
  • Publicado : 21 de novembro de 2012
Ler documento completo
Amostra do texto
Universidade CEUMACampus RenascençaCurso: Sistemas de InformaçãoDisciplina: AlgoritmoProfessora: AlessandraAluno: Fabricio Ferreira de AraújoCPD: 012427 |

Exercícios de Vetores
Questão 1:
algoritmo "Exercício Vetor 1"
// Função : Receber valores em vetores de 1 até 10 e tirar a média
// Autor : Fabricio Ferreira de Araújo
// Data : 28/10/2012
var
nota: vetor[1..10] de real // valoresdas notas
media,a,am: real // a = acumulador | am = acumulador média
x: inteiro // contador
inicio
// entrada de valores no vetor
para x de 1 ate 10 faca
escreva("Informe a nota do aluno: ")
leia(nota[x])
escreval("Nota de n° [",x, " ]")
escreval(" ")
a:=a+nota[x]
am:=am+1
fimpara

// tira média do aluno
media:=a/am
escreva("A média do aluno é: [", media, " ]")fimalgoritmo

Questão 2:
algoritmo "Exercício Vetor 2"
// Função : Entrar com 20 valores e desses valores retirar a media e imprimir os valores maiores que a média (>=7.0)
// Autor : Fabricio Ferreira de Araújo
// Data : 28/10/2012
var
num: vetor[1..20] de real // vetores
x,posicao,qtd: inteiro // x = contador | posicao = posição do numero | qtd = quantidade de numeros acima da médiaa,media,am: real // a = acumulador | am = acumulador média (para tirar média no final)
inicio
//entrada de vales no vetor
para x de 1 ate 20 faca
escreva("Número", x," de 20: ")
leia(num[x])
a:=num[x]+a
am:=am+1
fimpara
//listar números acima da média (7)
para x de 1 ate 20 faca
se (num[x] >= 7) entao
posicao:= x
qtd:=qtd+1
escreval("Os números acima damédia (7.0) são: [",num[x], " ] na posição: [",posicao, " ]")
fimse
fimpara
se (qtd > 0) entao
escreva("A quantidade de números acima da média são:", qtd)
fimse
//tirar média do vetor num[x]
escreval(" ")
media:= a/am
escreva("A média dos números: [", media, " ]")
fimalgoritmo

Questão 3:
algoritmo "Exerício Vetor 3"
// Função : Ler 100 valores fornecidos pelo usuário eentrar com um outro valor (num2) para verificar se o segundo valor entrado contem nos vetores e imprimir os valores maiores que o o fornecido
// Autor : Fabricio Ferreira de Araújo
// Data : 28/10/2012
var
num: vetor[1..100] de real // cadeia de vetores
a,num2,na: real // a = acumulador | num2 = Segundo valor de entrada | na = numero acima do num2
x,posicao: inteiro // x = contador | posicao =posição do vetor
inicio
// entrada de valeros no vetor
para x de 1 ate 100 faca
escreva("Valor [",x," ] de 100: ")
leia(num[x])
fimpara
escreval(" ")
escreva("Valor para pesquisa: ")
leia (num2)
escreval(" ")
// verifica se o número existe na cadeia de vetores e a posição
para x de 1 ate 100 faca
posicao:=x
se (num2 = num[x]) entao
escreval("Valor [",num2, " ]encontrado na cadeia de vetores na posição: [",posicao, " ]")
na:=na+1
fimse
fimpara
se (na = 0) entao
escreva("Nenhum número encontrado na cadeia de vetor.")
fimse
escreval(" ")
// imprime os números acima ou igual do valor entrado (num2)
para x de 1 ate 100 faca
se (num2 <= num[x]) entao
escreval("Valores iguais ou maiores que: [", num2," ] são: [",num[x], " ]")fimse
fimpara
fimalgoritmo

Exercícios de Matrizes
Questão 1:
algoritmo "Exercício Matriz 1"
// Função : Lê matriz A e B e soma os valores no vetor C
// Autor : Fabricio Ferreira de Araújo
// Data : 29/10/2012
var
a: vetor[1..1,1..10] de real // matriz a
b: vetor[1..1,1..10] de real // matriz b
c: vetor[1..1,1..10] de real // matriz c
x,y: inteiro // x = linha | y = coluna
inicio// inicia cadeia de matriz | lê matriz a,b
para x de 1 ate 1 faca
para y de 1 ate 10 faca
escreva("Elementos da [PRIMEIRA] matriz, linha[",x," ] coluna[",y," ]: ")
leia(a[x,y])
fimpara
fimpara
escreval(" ")
para x de 1 ate 1 faca
para y de 1 ate 10 faca
escreva("Elementos da [SEGUNDA] matriz, linha[",x," ] coluna[",y," ]: ")
leia(b[x,y])
fimpara...
tracking img