Algoritmo - conversores de moeda

Disponível somente no TrabalhosFeitos
  • Páginas : 10 (2320 palavras )
  • Download(s) : 0
  • Publicado : 23 de março de 2013
Ler documento completo
Amostra do texto
Etapa 3:


Passo1

Inicio inteiro: x[31]
Tipo VET: vetor[0..30] de inteiro;
VET: A;
Real: MEDIA,MAIOR,MENOR,SOMA,x;

SOMA(A[0];
MAIOR(A[0];
MENOR(A[0];

Para x de 0 até 30 passo 1 faça
Escreva(“Digite a cotação diária do EURO em Reais durante 1 mês”);
Leia(A[x]);
SOMA(SOMA+A[x];
Fimpara;
MEDIA((SOMA/31);
Escreva(“A média do EURO durante 1 mês é:” MEDIA);

Para x de 0 até 30passo 1 faça
Se(A[x] < MENOR) então
MENOR(A[x];
Fimse;
Fimpara
Escreva(“A menor cotação do EURO durante 1 mês foi:” Menor);

Para x de 0 até 30 passo 1 faça
Se(A[x] > Maior) então
MAIOR(A[x];
Fimse;
Fimpara;
Escreva(“A maior cotação do EURO durante 1 mês foi:” MAIOR);

Fim






Etapa 4

Passo 1




Inicio A[4][31], B[4]

Tipo Base: Matriz [0..3,0..30] de real;Base: A;
Inteiro: x,y;
Tipo Vet: Vetor[0..3] de caracter;
Vet: B;

Real:
MaiorReal, MaiorEuro, MaiorDolar, MaiorLibra, MenorReal, MenorEuro, MenorDolar, MenorLibra, MediaReal, MediaEuro, MediaDolar, MediaLibra, soma1, soma2, soma3,soma4;

B[0](Real;
B[1](Euro;
B[2](Dolar;
B[3](Libra;

MaiorReal (A[0][y]; MenorReal (A[0][y]; MediaReal (A[0][y];

MaiorEuro ( A[1[y]; MenorEuro (A[1][y]; MediaEuro A[1][y];

MaiorDolar ( A[2][y]; MenorDolar ( A[2][y]; MediaDolar ( A[2][y];

MaiorLibra ( A[3][y]; MenorLibra ( A[3][y]; MediaLibra ( A[3][y];


Para x de 0 ate 3 passo 1 faça

Para y de 0 ate 30 passo 1 faça
Escreva(“A cotação Diária de cada moeda”);
Leia([x][y]);
Fimpara;
Fimpara;






Para y de 0 ate 30 passo1 façasoma1(soma1+A[0][y];
fimpara;

MediaReal((soma1/31);
Escreva(“A média do Real durante o mês foi:” MediaReal);


Para y de 0 ate 30 passo1 faça
soma2(soma2+ A[1][y];
fimpara;

MediaEuro((soma2/31);
Escreva(“A média do Euro durante o mês foi:” MediaEuro);

Para y de 0 ate 30 passo1 faça
soma3(soma3+ A[2][y];
fimpara;

MediaDolar((soma3/31);
Escreva(“A média do Dolar durante o mês foi:”MediaDolar);

Para y de 0 ate 30 passo1 faça
soma4(soma4+ A[3][y];
fimpara;

MediaLibra((soma4/31);
Escreva(“A média da Libra durante o mês foi:” MediaLibra);


Para y de 0 ate 30 passo1 faça
Se (A[0][y] < MenorReal) entao
MenorReal( A[0][y];
Fimpara;

Escreva(“A menor cotação do Real durante o mês foi:” MenorReal);

Para y de 0 ate 30 passo1 faça
Se(A[1][y] < MenorEuro) entãoMenorEuro( A[1][y];
Fimpara;

Escreva(“A menor cotação do Euro durante o mês foi:” MenorEuro);


Para y de 0 ate 30 passo1 faça
Se (A[2][y] < MenorDolar) entao
MenorDolar( A[2][y];
Fimpara;

Escreva(“A menor cotação do Dolar durante o mês foi:” MenorDolar);





Para y de 0 ate 30 passo1 faça
Se (A[3][y] < MenorLibra) entao
MenorLibra( A[3][y];
Fimpara;

Escreva(“A menor cotação doLibra durante o mês foi:” MenorLibra);







Para y de 0 ate 30 passo1 faça
Se (A[0][y] > MaiorReal) entao
MaiorReal( A[0][y];
Fimpara;

Escreva(“A maior cotação do Real durante o mês foi:” MaiorReal);


Para y de 0 ate 30 passo1 faça
Se(A[1][y] > MaiorEuro) então
MaiorEuro( A[1][y];
Fimpara;

Escreva(“A maior cotação do Euro durante o mês foi:” MaiorEuro);

Para y de 0ate 30 passo1 faça
Se (A[2][y] > MaiorDolar) entao
MaiorDolar( A[2][y];
Fimpara;

Escreva(“A maior cotação do Dolar durante o mês foi:” MaiorDolar);

Para y de 0 ate 30 passo1 faça
Se (A[3][y] > MaiorLibra) entao
MaiorLibra( A[3][y];
Fimpara;

Escreva(“A maior cotação do Libra durante o mês foi:” MaiorLibra);

Fim
Etapa 4
Passo 2
Inicio A[4][30], B[4]

Tipo Base: Matriz[0..3,0..29] de real;
Base: A;
Inteiro: x,y, opção;
Tipo Vet: Vetor[0..3] de caracter;
Vet: B;

Real:
MaiorReal, MaiorEuro, MaiorDolar, MaiorLibra, MenorReal, MenorEuro, MenorDolar, MenorLibra, MediaReal, MediaEuro, MediaDolar, MediaLibra, soma1, soma2, soma3,soma4;

B[0](Real;
B[1](Euro;
B[2](Dolar;
B[3](Libra;

MaiorReal (A[0][y]; MenorReal (A[0][y]; MediaReal (A[0][y];

MaiorEuro...
tracking img