Algo

Disponível somente no TrabalhosFeitos
  • Páginas : 72 (17956 palavras )
  • Download(s) : 0
  • Publicado : 11 de maio de 2012
Ler documento completo
Amostra do texto
// Função : Preciso fazer um "Em Algoritmo logico" problema
// para meu curso q eh o seguinte:?
// Em uma eleição presidencial, existem 4 candidatos.
// Os votos são informados através de código.
// Os dados utilizados para a apuração obedecem
// a seguinte codificação:
// -1,2,3,4: Voto para os respectivos candidatos
// - 5: voto nulo
// -8: Voto em branco
// Elabore um programa quecalcule e escreva:
// * Total de votos para cada candidato
// * Total de votos nulos
// * Total de votos em branco
// * Informar a colocação dos candidatos
// Como finalizador do conjunto de votos use o valor 0.
// quem estiver on me mande agora por favor e obrigada
// Autor : eliane ezidio pereira
// Data : 18/6/2008
// Seção de Declarações
var

a, b, c, d, nulo, branco : inteirocod, opcao : caracter

inicio
a<-0
b<-0
c<-0
d<-0
nulo <- 0
branco <- 0
opcao <- "s"

enquanto (opcao = "s") faca
escreva ("Informe o código do candidato no qual votará: ")
leia (cod)
escolha cod
caso "1"
a <- a + 1
caso "2"
b <- b + 1
caso "3"
c <- c + 1
caso "4"
d <- d + 1
caso "5"
nulo <- nulo + 1
caso "8"
branco <- branco + 1outrocaso
escreval("ERRO!!! OPÇÃO NÃO ACEITA.")
fimescolha
escreva ("Deseja continuar?")
leia (opcao)
// Insira o comando LIMPA TELA
fimenquanto

// Informa a quantidade de votos para cada opção
escreval("Votos para o candidato A: ",a)
escreval("Votos para o candidato B: ",b)
escreval("Votos para o candidato C; ",c)
escreval("Votos para o candidato D: ",d)
escreval("Votos nulos: ",nulo)escreval("Votos em branco: ",branco)

// Informa a colocaçao de cada candidato
escreval (" COLOCAÇÃO DOS CANDIDATOS")

se (a > b) e (a > c) e (a > d) entao
.
.
.
.
.
.
.
.
// Está só faltando informar a colocação dos candidatos.
// Já dei uma forçona para você. Me desculpe se
// a resposta não foi completa.
// O algoritmo acima foi escrito no VisALG

fimalgoritmo//Função : Preciso fazer um "Em Algoritmo logico" problema
// para meu curso q eh o seguinte:?
// Em uma eleição presidencial, existem 4 candidatos.
// Os votos são informados através de código.
// Os dados utilizados para a apuração obedecem
// a seguinte codificação:
// -1,2,3,4: Voto para os respectivos candidatos
// - 5: voto nulo
// -8: Voto em branco
// Elabore um programa que calcule eescreva:
// * Total de votos para cada candidato
// * Total de votos nulos
// * Total de votos em branco
// * Informar a colocação dos candidatos
// Como finalizador do conjunto de votos use o valor 0.
// quem estiver on me mande agora por favor e obrigada
// Autor : eliane ezidio pereira
// Data : 18/6/2008
// Seção de Declarações
var

a, b, c, d, nulo, branco : inteiro
cod, opcao :caracter

inicio
a<-0
b<-0
c<-0
d<-0
nulo <- 0
branco <- 0
opcao <- "s"

enquanto (opcao = "s") faca
escreva ("Informe o código do candidato no qual votará: ")
leia (cod)
escolha cod
caso "1"
a <- a + 1
caso "2"
b <- b + 1
caso "3"
c <- c + 1
caso "4"
d <- d + 1
caso "5"
nulo <- nulo + 1
caso "8"
branco <- branco + 1
outrocasoescreval("ERRO!!! OPÇÃO NÃO ACEITA.")
fimescolha
escreva ("Deseja continuar?")
leia (opcao)
// Insira o comando LIMPA TELA
fimenquanto

// Informa a quantidade de votos para cada opção
escreval("Votos para o candidato A: ",a)
escreval("Votos para o candidato B: ",b)
escreval("Votos para o candidato C; ",c)
escreval("Votos para o candidato D: ",d)
escreval("Votos nulos: ",nulo)escreval("Votos em branco: ",branco)

// Informa a colocaçao de cada candidato
escreval (" COLOCAÇÃO DOS CANDIDATOS")

se (a > b) e (a > c) e (a > d) entao
.
.
.
.
.
.
.
.
// Está só faltando informar a colocação dos candidatos.
// Já dei uma forçona para você. Me desculpe se
// a resposta não foi completa.
// O algoritmo acima foi escrito no VisALG

fimalgoritmo// Função :...
tracking img