Trabalho visualg

Disponível somente no TrabalhosFeitos
  • Páginas : 14 (3483 palavras )
  • Download(s) : 0
  • Publicado : 27 de novembro de 2012
Ler documento completo
Amostra do texto
1. Escreva um algoritmo que armazene o valor 10 em uma variável A e o valor 20 em
uma variável B. A seguir (utilizando apenas atribuições entre variáveis) troque os seus
conteúdos fazendo com que o valor que está em A passe para B e vice-versa. Ao final,
escrever os valores que ficaram armazenados nas variáveis.

algoritmo "TROCA"

var
A, B, AUX: numerico
inicio
A<- 10
B <- 20
AUX <- 0
AUX <- A
A <- B
B <- AUX
escreva "O valor de A é: ", A, " e ", "O valor de B é: ", B
fimalgoritmo

2. Escreva um algoritmo para ler o número total de eleitores de um município, o número de votos brancos, nulos e válidos. Calcular e escrever o percentual que cada um representa em relação ao total deeleitores.

algoritmo "Eleiçoes"

var
teleitor, vnulos, vbrancos, vvalidos, pnulos, pbrancos, pvalidos :real
inicio
escrevaL ("Município de Fortaleza")
escrevaL ("Digite o total de eleitores do município ")
leia (teleitor)
escrevaL ("digite o total de VOTOS BRANCOS ")
leia (vbrancos)
escrevaL ("digite o total de VOTOS NULOS ")
leia(vnulos)
escrevaL ("digite o total de VOTOS VÁLIDOS ")
leia (vvalidos)
pbrancos <- (100*vbrancos)/teleitor
pnulos <- (100*vnulos)/teleitor
pvalidos <- (100*vvalidos)/teleitor
EscrevaL ("O percentual de VOTOS BRANCOS é ", pbrancos,"%")
EscrevaL ("O de VOTOS NULOS é ",pnulos,"%")
EscrevaL ("E o de VOTOS VÁLIDOS é ",pvalidos,"%")
Fimalgoritmo

3. O custo de um carro novo ao consumidor é a soma do custo de fábrica com a
porcentagem do distribuidor e dos impostos (aplicados ao custo de fábrica). Supondo
que o percentual do distribuidor seja de 28% e os impostos de 45%, escrever um
algoritmo para ler o custo de fábrica de um carro, calcular e escrever o custo final ao
consumidor.

algoritmo "Carronovo"

var
cfabrica, pimp, pdist, tfinal: real
inicio
escreva ("Digite o CUSTO DE FABRICA do carro ")
leia (cfabrica)
pimp <- (0.28*cfabrica)
pdist <- (0.46*cfabrica)
tfinal<- (cfabrica + pimp + pdist)
Escreva ("O valor final do carro novo para o cliente é de " ,tfinal)
Fimalgoritmo

4. Uma revendedora de carros usados paga a seus funcionários vendedores umsalário
fixo por mês, mais uma comissão também fixa para cada carro vendido e mais 5% do
valor das vendas por ele efetuadas. Escrever um algoritmo que leia o número de
carros por ele vendidos, o valor total de suas vendas, o salário fixo e o valor que ele
recebe por carro vendido. Calcule e escreva o salário final do vendedor.

algoritmo "Revendedora"

var
cvendidos, tvendas,salfixo, vcvendido, valor5, salfinal :real
inicio
escrevaL ("Vendedor 1")
EscrevaL ("Quantos carros foram vendidos? ")
leia (cvendidos)
escrevaL ("qual o valor total das vendas? ")
leia (tvendas)
escreva ("o salario fixo desse vendedor ")
leia (salfixo)
escrevaL ("Quanto recebe por cada carro vendido? ")
leia (vcvendido)
valor5 <-(0.05*tvendas)
salfinal <- (salfixo + valor5 + vcvendido)
fimalgoritmo

5. Escreva um algoritmo para ler uma temperatura em graus Fahrenheit, calcular e escrever o valor correspondente em graus Celsius (baseado na fórmula abaixo): C = 5/9 * (F - 32)
Observação: Para testar se a sua resposta está correta saiba que 100C = 212F

algoritmo "graus"

var
f, c :real

inicioescrevaL("Diga-me qual a temperatura - em Fahrenheit- deseja saber em")
escreva("Celsius?")
leia (f)
c <- (5/9)*(f-32)
EscrevaL("A temperatura em graus Celsius é", c)
fimalgoritmo

6. As maçãs custam R$ 1,30 cada se forem compradas menos de uma dúzia, e R$ 1,00 se forem compradas pelo menos 12. Escreva um programa que leia o número de...
tracking img