Trabalho agloritmos visualg

Disponível somente no TrabalhosFeitos
  • Páginas : 7 (1593 palavras )
  • Download(s) : 0
  • Publicado : 24 de outubro de 2012
Ler documento completo
Amostra do texto
ELSON SARAIVA DE ARAUJO – RGM 121814-0

TRABALHO ACADÊMICO ALGORITMOS: LISTA DE EXERCÍCIOS

Brasília-DF, 28 de Setembro de 2012

1

SUMÁRIO

Introdução____________________________________________________________3 Desenvolvimento Algoritmo 1 ___________________________________________________________4 Resposta Algoritmo 1 ___________________________________________________4 Algoritmo 4___________________________________________________________6 Resposta Algoritmo 4 ___________________________________________________7 Algoritmo 5 ___________________________________________________________9 Resposta Algoritmo 5 ___________________________________________________9 Algoritmo 6___________________________________________________________11 Resposta Algoritmo 6__________________________________________________11 Algoritmo 7 __________________________________________________________13 Resposta Algoritmo 7 __________________________________________________14 Algoritmo 8 __________________________________________________________17 Resposta Algoritmo 8 __________________________________________________19 Algoritmo 9___________________________________________________________23Resposta Algoritmo 9 __________________________________________________24 Conclusão ___________________________________________________________27

2

INTRODUÇÃO

Este trabalho tem por finalidade desenvolver

a lógica de programação para

solucionar problemas ou aplicações que forem necessárias. Para este trabalho estarei utilizando a linguagem PORTUGOL, e a aplicação VisualG paradesenvolvimento das soluções propostas pela lista de exercícios.

3

Algoritmo 1
Construa um algoritmo que permita fazer um levantamento do estoque de vinhos de uma adega, como dados de entrada o código do vinho (1-vinho tinto, 2-vinho branco e 3- vinho rose). Especifique a percentagem de cada tipo sobre o total geral de vinhos. Encerra quando o código for 999.

Resposta Algoritmo 1 algoritmo"exercicio01" // Função : Ciclo de Repetição // Autor : Elson Saraiva de Araújo var tipo:caractere tinto, branco, rose: inteiro quanttinto, quantbranco, quantrose, total: real cont: inteiro inicio tinto:=0 branco:=0 rose:=0 total:=0
4

enquanto total999 faca escreva(">>> Entre Tipo do Vinho ") Leia (tipo) se (tipo="tinto") entao tinto:=tinto+1 fimse se (tipo="branco") entao branco:=branco+1 fimse se(tipo="rose") entao rose:=rose+1 fimse total:= total +1 limpatela fimenquanto quanttinto:=tinto/10 escreval("Quantidade de vinho Tinto: ",quanttinto:3:2,"%") quantbranco:=branco/10 escreval("Quantidade de vinho Seco: ",quantbranco:3:2,"%") quantrose:=rose/10 escreval("Quantidade de vinho Rose: ",quantrose:3:2,"%")
5

fimalgoritmo

Algoritmo 4 Determinada cidade avalia o preço da energiaelétrica baseada na seguinte classificação de tipo de consumo: Residência = R Hotel=H Fabrica =F Parque =P Comercio =C Escola=E Igreja = I Aeroporto = A

Faça um programa que apresente as seguintes informações: 1. Total de KWh consumidos pelos hotéis, parques, escolas e aeroportos em conjunto; 2. Quantia média despendida pelas fabricas; 3. Valor total pago por todos os outros tipos de usuários.Encerra quando código = “S”. O preço do kWh é de r$ 0.37 para todos os usuários.
6

Resposta Algoritmo 4 algoritmo "Exercicio004" // Função : Cálculo conta Energia // Autor : Elson Saraiva de Araújo var codigo: caractere mediahpea,consumof, mediaf, mediarci, total, preco, kwh: real inicio preco:=0,37 mediahpea:=0 mediaf:=0 mediarci:=0 consumof:=0 enquanto codigo "s" faca escreval ("Entre comcódigo ") leia(codigo) escreval ("Entre com kWh ") leia (kwh)
7

se (codigo="h")ou (codigo="p")ou(codigo="e")ou(codigo="a") entao mediahpea:=mediahpea+kwh fimse se (codigo="f") entao consumof:= kwh*0.37 mediaf:=mediaf+consumof fimse se (codigo="c") ou (codigo="r") ou (codigo="i") entao mediarci:= mediarci+(kwh*0.37) fimse limpatela fimenquanto escreval("Total consumido por Hóteis, Parques,...
tracking img