Trabalho algoritmos com suas respectivas respostas

Disponível somente no TrabalhosFeitos
  • Páginas : 5 (1012 palavras )
  • Download(s) : 0
  • Publicado : 19 de março de 2013
Ler documento completo
Amostra do texto
Exercicio (01)
algoritmo "ex1"
// Função : Faça um algoritmo que receba dois números e exiba o resultado da sua soma.
// Autor :
// Data : 30/11/2010
// Seção de Declarações
var
x, y: inteiro

inicio
// Seção de Comandos
escreval("Digite o primeiro número: ")
leia(x)
escreval("Digite o segundo número: ")
leia(y)
escreva("A soma dos números é: ",x+y)
fimalgoritmo

Exercicio(02)algoritmo "ex2"
// Função : Faça um algoritmo que receba dois números e ao final mostre a soma, subtração, multiplicação e a divisão dos números lidos.
// Autor :
// Data : 30/11/2010
// Seção de Declarações
var
x, y: real

inicio
// Seção de Comandos
escreva("Digite o primeiro número: ")
leia(x)
escreva("Digite o segundo número: ")
leia(y)
escreval("A soma é: ",x+y)
escreval("Asubtração é: ",x-y)
escreval("A multiplicação é: ",x*y)
escreval("A divisão é: ",x/y)

Exercicio(03)
algoritmo "ex3"
// Função : Escrever um algoritmo para determinar o consumo médio de um automóvel
// sendo fornecida a distância total percorrida pelo automóvel e o total de combustível gasto.
// Autor :
// Data : 30/11/2010
// Seção de Declarações
var
distancia, combustivel: realinicio
// Seção de Comandos
escreval("========== Cálculo de consumo médio de combustível =========")
escreva("Digite a distância pecorrida: ")
leia(distancia)
escreva("Digite o combustível gasto: ")
leia(combustivel)
escreval("O consumo médio de combustível do seu veículo é: ",distancia/combustivel)

fimalgoritmo
Exercicio(04)
algoritmo "ex4"
// Função : Escrever um algoritmo que leiao nome de um vendedor, o seu salário fixo e o total de vendas efetuadas por ele no
// mês (em dinheiro). Sabendo que este vendedor ganha 15% de comissão sobre suas vendas efetuadas, informar o
// seu nome, o salário fixo e salário no final do mês
// Autor :
// Data : 30/11/2010
// Seção de Declarações
var
nome: caractere
salario: real
vendas: real
comissao: real
salarioFinal: realinicio
// Seção de Comandos
escreval("<><><><><> Sistema de gestão de vendedores <><><><><>")
escreva(">>> Digite o nome do vendedor: ")
leia(nome)
escreva(">>> Digite o salário: ")
leia(salario)
escreva(">>> Informe a quantidade de vendas deste no mês: ")
leia(vendas)
// Cálculo da comissão e saláriofinal
comissao <- 0.15 * vendas
salarioFinal <- salario + comissao
limpatela
escreval(">>>>>>>>>> RESUMO <<<<<<<<<<")
escreval("-- Nome: ",nome)
escreval("-- Salário: ",salario)
escreval("-- Salário Final (salário + comissão): ",salarioFinal)escreval(">>>>>>>>>><><><><><<<<<<<<<<")
fimalgoritmo

Exercicio(05)
algoritmo "ex5"
// Função : Escrever um algoritmo que leia o nome de um aluno e as notas das três provas que ele obteve no semestre. No final
// informar o nome do aluno e a sua média (aritmética)
// Autor :
// Data : 30/11/2010
// Seção de Declarações
var
aluno: caractere
notas: vetor[1..3] de real
x: inteiromedia: real

inicio
// Seção de Comandos
escreval("============== Média de alunos ==============")
escreva("Digite o nome do aluno: ")
leia(aluno)
para x de 1 ate 3 faca
escreva("Digite a ",x,"º nota ")
leia(notas[x])
fimpara
media <- (notas[1] + notas[2] + notas[3]) / 3
limpatela
escreval("==============", aluno," ==============")
escreval(">>> Média: ",media)escreval("=======================================")
fimalgoritmo

Exercicio(06)
algoritmo "ex6"
// Função : Ler dois valores para as variáveis A e B, e efetuar as trocas dos valores de forma que a variável A passe a possuir o
// valor da variável B e a variável B passe a possuir o valor da variável A. Apresentar os valores trocados.
// Autor :
// Data : 30/11/2010
// Seção de Declarações...
tracking img