Sistema

Disponível somente no TrabalhosFeitos
  • Páginas : 4 (884 palavras )
  • Download(s) : 0
  • Publicado : 4 de outubro de 2011
Ler documento completo
Amostra do texto
linguagens e técnicas de programação:

SUMÁRIO

1- algoritmo CONBUSTIVEL
2- algoritmo PRODUÇÃO
3- algoritmo PLANO_SAUDE
4- algoritmo SALARIO_BRUTO
5- algoritmo REPETIÇÃO

INTRODUÇÃOEste trabalho visa uma maior compreensão da linguagem de programação da linguagem pseudocódigo.

REFERÊNCIAS
WWW.GOOGLE.COM.BR
* Atividade Produção Textual
algoritmo"CONBUSTIVEL"
// Função : Calcula a quantidade de litros de combustível gasto na viagem
// Autor : Felipe castro da Silva
// Data : 24/5/2010
// Seção de Declarações
var
DISTANCIA, TEMPO,VELOCIDADE, LITROS_GASTOS : REAL
inicio
Escreval("Tempo da Viagem : ")
leia(TEMPO)
Escreval("Velocidade Média : ")
leia(VELOCIDADE)
DISTANCIA <- TEMPO * VELOCIDADE
LITROS_GASTOS <-DISTANCIA / 12
limpatela
Escreval(" Tempo da Viagem : ",TEMPO)
Escreval("Velocidade Média :",VELOCIDADE)
Escreval("Distância :",DISTANCIA)
Escreval("Litros Usados :",LITROS_GASTOS)
fimalgoritmo1.
algoritmo "PRODUÇÃO"
// Função : Calcula salario + produção do funcionário
// Autor : Felipe castro da Silva
// Data : 24/5/2010
// Seção de Declarações
var
SALARIO_FINAL, ADCIONAL,QTDE : REAL
inicio
SALARIO_FINAL <- 240
Escreval(" Produção de Peças no Mês :")
leia(QTDE)
se (QTDE < 501) entao
ADCIONAL <- 0
senao
se (QTDE > 500) e (QTDE < 751) entaoADCIONAL <- QTDE-500
ADCIONAL <- (ADCIONAL*50)/100
senao
se (QTDE > 750) entao
ADCIONAL <- QTDE-750
ADCIONAL <- (ADCIONAL*75)/100ADCIONAL <- ADCIONAL + 350
SALARIO_FINAL <- 350
fimse
fimse
fimse
limpatela
Escreval(" Adicional do Funcionário R$: ",ADCIONAL)
SALARIO_FINAL<- SALARIO_FINAL + ADCIONALEscreval(" Salário do Mês : R$",SALARIO_FINAL)
fimalgoritmo

2.
algoritmo "PLANO_SAUDE"
// Função : Calcula valores dos planos de saúde do governo
// Autor : felipe casro da...
tracking img