Metodo numerico portugol

Disponível somente no TrabalhosFeitos
  • Páginas : 3 (716 palavras )
  • Download(s) : 0
  • Publicado : 13 de junho de 2011
Ler documento completo
Amostra do texto
Escreva um procedimento que receba um número inteiro e o escreva na forma extensa. Por exemplo, para 1 a saída desejada é “Um”. A função deve ser capaz de gerar o extenso dosnúmeros de 0 até 10, inclusive. Caso um número não compatível seja recebido o procedimento deve mostrar uma mensagem de erro. Crie também um algoritmo que leia um valor inteiro e chame oprocedimento criado acima para a impressão do número extenso.

algoritmo { transforma arábico em extenso }
{ NE = numero por extenso }
{ N = numero inserido }

declare N,NUM numérico;
declare NE literal

função_literal EXTENSO(NE);

para i = 0 até 10 faça;
se N = i faça

se NUM[i]=0
NE ( zero

Senãose NUM[i]=1
NE( um

Senão se NUM[i]=2
NE( dois

.
.
.

se NUM[i]=10
NE(dez
Fim se
Fim se
Fim para
Fim função EXTENSOleia(N);
se ( N < 0 ) ou( N > 10) então
escreva("Erro! Número inválido!");
senão
escreva(EXTENSO[NE]);
fim-se
Fim algoritmo

Um número é dito ser capicuaquando lido da esquerda para a direita é o mesmo que
quando lido da direita para a esquerda. O ano 2002, por exemplo, é capicua. Então, elabore uma função para verificar se um número possuiessa característica. Caso o número seja capicua, a função deve retornar 1 e 0 em caso contrário. Escreva também um algoritmo para testar tal função.

algoritmo CAPICUA

declare N, RET, INV,NUMnumérico

INV ( 0;

Função_numérico INVERSO(NUM)

enquanto( NUM ≠ 0 ) faça
RET ( NUM mod10;
NUM (- NUM div10;
INV ( REV * 10 + RET;fim-enquanto

INVERSO ( INV;
Fim-função_inverso

Função_logico CAPICUA(NUM);

se (INVERSO (NUM) = NUM ) então
CAPICUA ( verdadeiro;
Senão
CAPICUA ( falso;...
tracking img