Exercicios de algoritmos

Disponível somente no TrabalhosFeitos
  • Páginas : 3 (685 palavras )
  • Download(s) : 0
  • Publicado : 25 de maio de 2012
Ler documento completo
Amostra do texto
LISTA 5 DE ALGORITMOS

1) PROGRAMA NOVO SALÁRIO
VAR
REAL SAL, SAL_NOVO.
INICIO
ESCREVA: (“INFORME O SALÁRIO ATUAL: R$”)
LEIA (SAL)
SE (SAL < 500) ENTÃO
SAL_NOVO ← SAL + (SAL *0,15)
SENAO
SE (SAL >= 500 E SAL <= 1000) ENTÃO
SAL_NOVO ← SAL + (SAL * 0,10)
SENAO
SAL_NOVO ← SAL + (SAL * 0,05)
FIMSE
FIMSE
ESCREVA (“O SALÁRIO COM REAJUSTE É:R$”, SAL_NOVO)
FIM

INICIO
FLUXOGRAMA:

“O SALÁRIO COM REAJUSTE É: R$”, SAL_NOVO.
SAL_NOVO ← SAL + (SAL * 0,05)

SAL >= 500 E SAL <= 1000
SAL_NOVO ← SAL + (SAL * 0,10)

SAL_NOVO ←SAL + (SAL * 0,15)
SAL < 500
SAL
“INFORME O SALÁRIO ATUAL: R$”
REAL SAL, SAL_NOVO.

N S

FIM
N S






2) PROGRAMA TERMÔMETRO
VAR
REAL T
INICIO
ESCREVA:(“INFORME A TEMPERATURA: °C”)
LEIA (T)
SE (T < 100) ENTÃO
ESCREVA (“A TEMPERATURA ESTÁ MUITO BAIXA”)
SENAO
SE (T >= 100 E T <= 200) ENTÃO
ESCREVA (“A TEMPERATURA ESTÁBAIXA”)
SENAO
SE (T >200 E T < 500) ENTÃO
ESCREVA (“A TEMPERATURA ESTÁ NORMAL”)
SENÃO
ESCREVA (“A TEMPERATURA ESTÁ MUITO ALTA”)
FIMSE
FIMSEFIMSE
FIM
































INICIO
FLUXOGRAMA:

REAL T

“INFORME A TEMPERATURA: °C”

T

T< 100N S

N
S
T >= 100 E T <= 200
“A TEMPERATURA ESTÁ MUITO BAIXA”


N
S
“A TEMPERATURA ESTÁ BAIXA”
T > 200 E T <500

“A TEMPERATURA ESTÁ MUITO ALTA”
“A TEMPERATURAESTÁ NORMAL”

FIM





3) PROGRAMA PROCEDÊNCIA
VAR
REAL PR, CO.
INICIO
ESCREVA (“INFORME O PREÇO DO PRODUTO: R$”)
LEIA (PR)
ESCREVA (“INFORME O CÓDIGO DE ORIGEM:”)LEIA (CO)
SE (CO = 1) ENTÃO
ESCREVA (“O PREÇO DO PRODUTO É: R$”, PR, “PRODUTO DA REGIÃO SUL”).
SENAO
SE (CO = 2) ENTÃO
ESCREVA (“O PREÇO DO PRODUTO É: R$”, PR, “PRODUTO...
tracking img