Algoritmos

Disponível somente no TrabalhosFeitos
  • Páginas : 6 (1359 palavras )
  • Download(s) : 0
  • Publicado : 21 de outubro de 2012
Ler documento completo
Amostra do texto
Centro Universitário Anhanguera
Campus II – Campo Grande - MS
Disciplina: Algoritmos e Programação
Turma:Engenharias A e B – Profª.: Luciene de O. Marin
1ª Lista de Exercícios
1) Assinalar os identificadores válidos
( ) ALICE
( ) SALARIOMINIMO
( ) 1A1B1C
( ) A1B1C1
( ) EU_E_VOCE
( ) TRESVEZESQUATRO
( ) NOIS
( ) ZERO
( ) “NOME”

(
(
(
(

) 3x4
) M2
) MEU
) CERTO

(
(
((

) EU*E*VOCÊ
)HEIN!
) A-B
) KM/H

2) Sendo A,B,C,D,E variáveis do tipo numérico quais os resultados obtidos por cada uma da seguintes funções,
onde A = 13; B = 2; C = 4,8 ; D = 5,1 ; E = 13
a) QUOCIENTE (A,B) e RESTO(A,B) =
b) SINAL (A+B-E) =
c) ARREDONDA(A+C) =
d) TRUNCA(A + C) =
e) ABS(A-B2 + D) =
f) EXP(A - E) =
3) Dadas as variáveis numéricas A, B, C e as variáveis literaisNOME e ESPORTE, resolva as relações abaixo:

A

B

C

Variáveis
NOME

ESPORTE

3
2
1

2
3
4

16
10
7

“JOSÉ”
“MARIA”
“PEDRO”

“FUTEBOL”
“TÊNIS”
“GOLFE”

A+B2>C

Relações
ESPORTE = “GOLFE”

NOME ≠ “JOSÉ”

4) Baseando-se nas seguintes declarações, marque C ( Certo) ou E (Errado) para as atribuições:
A, E, I, X, Z
são variáveis Numéricas
K, L, M
sãovariáveis Literais
C1, C2
são variáveis Lógicas
( ) A ← “A”
( ) X ← CINCO
( ) C1 ← F

( ) E ← 4350
( ) Z ← 2030
( ) M ← “QUATRO”

( ) C2 ← falso
( ) L ← UFSC
( ) K ← “1234”

( )I←1
( ) C2 ← X > Z

5) Baseando-se nas seguintes atribuições, marque nos parênteses os valores lógicos das expressões :
X ← 100 Y ← 2,5
Z ← 23
A ← “AMIGO”
B←5 Y
) “AMIGA” ≠ A
) B ou C < “A”
) V e Z = X ounão F
) não ( X+ D < Z ) ou X ≠ Y
) Y = D*2 e X ≤ 0 ou X ≠ Y
)Y = D*2 e (X ≤ 0 ou X ≠Y )
) A = “AMIGA” e não B

1

6) Dado o algoritmo abaixo, responda
início-algoritmo
declare B1, B2, B3: lógico
se (B1) então
C1;
senão
se (B2) então
se (B3) então
C 2;
senão
C 3;
C 4;
fim-se
fim-se
fim-se
C5;
fim-algoritmo
Se B1= verdadeiro, B2 = verdadeiro, B3 = falso, quais os comandos queserão executados ?
Se B1= falso, B2 = verdadeiro, B3 = falso, quais os comandos que serão executados ?
Quais os valores de B1, B2, B3 para que somente o comando C5 seja executado?
Se B1= falso, B2 = verdadeiro, B3 = Verdadeiro, quais os comandos que serão executados ?
7) Dado o algoritmo abaixo, responda
início-algoritmo
declare A, B, C
: lógico
declare X, Y, V,L
: numérico
L ← 2;
A ←falso; B ← verdadeiro; C ←falso;
X ← 1,5; Y ←3,2;
X ← X + 1;
se (C ou ( (X + Y > 5) ou ( não A e B)))
L ← 0;
fim-se
fim-algoritmo

então

Qual o valor de L após a execução deste trecho de algoritmo ?
8) Quais as saídas do algoritmo abaixo:
início-algoritmo
declare A, B, T: numérico
escreva “Digite dois números”
leia A, B
T←A
A←B
B←T
escreva A, B
fim-algoritmo
para A = 1 e B =5, A = 7 e B = 9
9) Quais as saídas do algoritmo abaixo:
início-algoritmo
declare A, B: numérico
escreva “Digite dois números”
leia A, B
A←A+B
B←A-B
A←A-B
escreva A, B
fim-algoritmo
para A = 1 e B = 5, A = 7 e B = 9

2

10) Dado o algoritmo abaixo, responda
início-algoritmo
declare NÚMERO, A, B, C, D: numérico
NÚMERO ← 1352;
D ← RESTO ( NÚMERO,10);
C ← RESTO (QUOCIENTE (NÚMERO,10), 10);
B ← RESTO (QUOCIENTE ( NÚMERO,100), 10);
A ← RESTO (QUOCIENTE ( NÚMERO,1000), 10);
escreva A, B, C, D
fim-algoritmo
Quais os valores escritos pelo algoritmo?
11) Quais os resultados produzidos pelo algoritmo que se segue ?
início-algoritmo
declare Y: numérico
declare X: lógico
Y ← 0;
X ← falso;
enquanto (Y ≠ 6) faça
X ← não X;
Y ← Y + 1;
se ( X ) então
escreva ( Y )senão
escreva ( -Y )
fim-se
fim-enquanto
fim-algoritmo
12) Quais os resultados produzidos pelo algoritmo que se segue se :
a) NUM = 10

b) NUM = 0

c)NUM = -47

início-algoritmo
declare NUM: numérico
declare QUALE: literal
escreva “Digite um número”
leia NUM
se (NUM > 0) então
QUALE ← “NÚMERO POSITIVO”;
senão
se ( NUM < 0 ) então
QUALE ← “NÚMERO NEGATIVO”;
senão
QUALE ←...
tracking img