Algoritmos resolvidos - iniciantes

Disponível somente no TrabalhosFeitos
  • Páginas : 2 (307 palavras )
  • Download(s) : 0
  • Publicado : 30 de novembro de 2012
Ler documento completo
Amostra do texto
Considerar que uma pessoa atinge a maioridade ao completar 18 anos. Fazer um algoritmo que leia a idade de uma pessoa e escreva se ela é maior ou menor de idade. algoritmo "maioridade"// Data : 25/03/2010 var idade:real inicio escreval ("Digite sua idade") leia (idade) Se idade < 18 entao escreval ("Menor de idade") senao escreval ("Maior de idade") fimsefimalgoritmo algoritmo "NOTA" // Data : 25/03/2010 var nota:real inicio escreval ("Digite sua nota") leia (nota) Se nota < 6 entao escreval ("REPROVADO") senao escreval ("APROVADO") fimsefimalgoritmo

Fazer um algoritmo que leia a nota final de um aluno e escreva se ele foi aprovado ou não (considerar nota final maior ou igual a seis para aprovação).

Fazer um algoritmoque leia três notas (números com casas decimais) de um aluno e a quantidade de faltas (número inteiro) escrevendo o conceito (número inteiro) deste aluno. O algoritmo deverá calcular amédia aritmética das notas e determinar o conceito a partir da tabela abaixo. Além disto, o aluno, para ser aprovado, deverá ter no máximo cinco faltas, caso contrário o conceito serázero.

O índice de massa corporal (IMC) é calculado dividindo-se o peso de uma pessoa pela sua altura ao quadrado. A partir do valor de IMC podemos classificar a pessoa quanto ao pesoconforme os intervalos apresentados a seguir (revista Galileu nov2004) : IMC . Fazer um algoritmo que leia o peso e a altura de uma pessoa, escrevendo a classificação desta pessoa.Fazer um algoritmo que leia um número (considere números de 5 dígitos). Escreva quantos algarismos deste número são ímpares e também a soma dos algarismos pares. algoritmo "pares,impares"// Data : 06/04/2010 var d1,d2,d3,d4,d5, soma, impar: inteiro inicio escreval ("Digite um numero de 5 digitos. Após cada algarismo digitado pressione enter.") leia (d1,d2,d3,d4,d5) impar
tracking img