Algoritmo para converter valores de moedas

Disponível somente no TrabalhosFeitos
  • Páginas : 2 (305 palavras )
  • Download(s) : 0
  • Publicado : 23 de setembro de 2012
Ler documento completo
Amostra do texto
Conversor de moedas

• Dados de entrada: informar qual a moeda estrangeira para que o valor seja convertido, o valor em real a ser convertido e a cotação atual da moeda para o qual irá converter.•Processamento: realização do calculo para conversão da moeda.
•Dados de saída: valor convertido do real para a moeda estrangeira selecionada.

Descrição narrativa do algoritmo

O algoritmo irámostrar na tela um menu das opções de moedas que podem ser convertidas, logo em seguida irá pedir o valor para conversão, depois valor atual da moeda estrangeira escolhida e assim por final mostrando oresultado da conversão da moeda.


Algoritmo

var

opcao:inteiro
resposta:caracter
moeda1:real
moeda2:real

inicio

repita

escreval ("Menu de moedas para conversão")
escreval ()escreval ("1.Dolar Americano - Turismo (US$)")
escreval ("2.Dolar Canadense - (CDN$)")
escreval ("3.Euro - (€)")
escreval()
escreval()

escreva ("Digite a opção desejada domenu acima: ")
leia(opcao)
enquanto (opcao3) faca
escreva ("Digite um opção valida do menu acima: ")
leia (opcao)
fimenquanto
escreval()

escreva ("Digite o valor doreal (R$) para conversão: ")
leia (moeda1)
escreval()

escreva ("Digite o valor da cotação atual da moeda escolhida: ")
leia (moeda2)
escreval()

se (opcao=1) entaoescreva("Valor do real (R$) para conversão: ")
escreval(moeda1)
escreva("Valor da cotação atual do Dolar (U$$): ")
escreval(moeda2)
escreva("Resultado da conversão:",moeda1/moeda2:2," U$$")
escreval()
fimse

se (opcao=2) entao
escreva("Valor do real (R$) para conversão: ")
escreval(moeda1)
escreva("Valor da cotação atual do DolarCanadense (CND$): ")
escreval(moeda2)
escreva("Resultado da conversão: ",moeda1/moeda2:2," CND$")
escreval()
fimse

se (opcao=3) entao
escreva("Valor do real (R$)...
tracking img