Wasley

Disponível somente no TrabalhosFeitos
  • Páginas : 2 (267 palavras )
  • Download(s) : 0
  • Publicado : 24 de outubro de 2012
Ler documento completo
Amostra do texto
var
ni,i:real
sexo,es:caracter
nsf,nsm:real
idmhe:real
ph,nmces,mi:real
inicio
ni<-0
i<-0
nsf<-0
nsm<-0
idmhe<-0
ph<-0nmces<-0
mi<-0
escreval("Qual o numero de iscriçao do candidato?")
leia(ni)
enquanto ni <> 999 faca
escreval("Qual a idade docandidato?")
leia(i)
escreval("Qual o sexo do candidato?")
leia(sexo)
escreval("O candidato possui experiencia no serviço?")
leia(es)
se (es="sim")entaoescreval("Candidato possui experiencia")
fimse
se (es="nao")entao
escreval("Candidato nao possui experiencia")
fimse
se (sexo="masculino")entaonsm<-nsm+1
escreval("Candidato do sexo masculino")
fimse
se (es="sim") entao
idmhe<-i/nsm
fimse
se (sexo="masculino") e (i>45)entaoph<-nsm+1*10/100
fimse
se(sexo="feminino")entao
nsf<-nsf+1
escreval("Candidato do sexo feminino")
fimse
se (sexo="feminino") e (i<35)e (es="sim")entao
nmces<-nmces+1
mi<-i
fimse
escreval("Qual o numero de iscriçao do candidato?")
leia(ni)
fimenquanto
escreval("O número de candidatosdo sexo feminino é",nsf)
escreval("O número de candidatos do sexo masculino é",nsm)
escreval("A idade média dos homens que já têm experiência noserviço é",idmhe)
escreval("Porcentagem dos homens com mais de 45 anos entre o total de homens é",ph,"%")
escreval("O número de mulheres que têm idadeinferior a 35 anos e com experiência no serviço é",nmces)
escreval("A menor idade entre mulheres que já têm experiência no serviço é",mi)
fimalgoritmo
tracking img