Visulag

Disponível somente no TrabalhosFeitos
  • Páginas : 2 (422 palavras )
  • Download(s) : 0
  • Publicado : 2 de julho de 2012
Ler documento completo
Amostra do texto
Turma 710 – Andréa Gomes
Trabalho de VisuAlg
algoritmo "Exercício 01"
// Função : se
// Autor : Andréa Gomes
// Data : 18/6/2010
var
x: inteiro
inicio
escreva ("Digite um número: ")
leia(x)
se (x%2=0) entao
escreval ("O número é Par.")
senao
escreval ("O número é Ímpar.")
fimse
fimalgoritmo

algoritmo "Exercício 02"
// Função : SE
// Autor : Andréa Gomes
// Data : 18/6/2010var
x: inteiro
inicio
escreva ("Digite um número: ")
leia (x)
se (x%3=0) e (x%6=0) e (x%10=0) entao
escreval ("É divisível por 3, 6 e 10.")
senao
escreval ("O número não é divisível por 3,6 e10.")
fimse
fimalgoritmo

algoritmo "Exercício 03. Quantidade de água ingerida ao dia"
// Função : SE
// Autor : Andréa Gomes
// Data : 18/6/2010
var
x, y: real
inicio
escreva ("Quantoslitros de água vc ingere por dia? ")
leia (x)
se (x=2) entao
escreval (x, " litros: Quantidade ideal!")
senao
se (x<2) entao
y<- 2-x
escreval ("Precisa beber mais água:", y, " litros.")senao
se (x>2) entao
escreval ("Quantidade correta.")
fimse
fimse
fimse
fimalgoritmo

algoritmo "Exercício 04. Calculo IMC"
// Função :
// Autor : Andréa Gomes
// Data : 18/6/2010
var
p,a,imc: real
inicio
escreva ("Qual seu peso? ")
leia (p)
escreva ("Qual sua altura? ")
leia (a)
imc<- (p/(a^2))
se (imc<18.5) entao
escreval (imc, " Você está abaixo do peso ideal.")senao
se (imc>=18.5) e (imc<=24.9) entao
escreval (imc, "Parabéns - você está em seu peso normal!")
senao
se (imc>=25) e (imc<=29.9) entao
escreval (imc, " Você está acima de seu peso(sobrepeso).")
senao
se (imc>=30) e (imc<=34.9) entao
escreval (imc, " Obesidade grau I.")
senao
se (imc>=35) e (imc<=39.9) entao
escreval (imc, " Obesidade grau II.")
senao
se(imc>=40) entao
escreval (imc, " Obesidade grau III.")
fimse
fimse
fimse
fimse
fimse
fimse
fimalgoritmo

algoritmo "Exercício 05"
// Função :
// Autor : Andréa GOmes
// Data : 19/06/2011...
tracking img