Trabalho de processamento de dados

Disponível somente no TrabalhosFeitos
  • Páginas : 2 (273 palavras )
  • Download(s) : 0
  • Publicado : 13 de junho de 2012
Ler documento completo
Amostra do texto
Construa um algoritmo que indique qual a melhor forma de pagamento para a compra realizada por uma empresa. Essa compra é composta por vários produtos e a entrada de dados deveparar quando o usuário digitar como quantidade um valor negativo. O algoritmo deve ler a quantidade de dinheiro existente no caixa de uma empresa (CAIXA), a quantidade de cadaitem comprado (QTD) e o preço de cada produto (PR). Caso o valor total da compra SEja superior a 80% do valor em caixa, a compra deve SEr feita a prazo (3x), com juros de 10%sobre o valor total. Caso contrário, a compra dever SEr realizada a vista, onde a empresa receberá 5% de desconto. Ao final apreSEntar a forma de pagamento escolhida e o valor aSEr pago (total a vista ou total a prazo), dependendo da escolha realizada pelo algoritmo.
ALGORITMO “Forma de pagamento”
VAR:
CAIXA, COMPRA, QTD, PR: INTEIROTOT_CAIXA, PRID, APRAZO, PARCELA, DESCONTO: REAL
INICIO
REPITA
ESCREVAL("Informe o valor existente em caixa (R$):")
LEIA(CAIXA)
ESCREVAL("Informe a quantidade de itenscomprados:")
LEIA(QTD)
ESCREVAL("Informe o preço do item comprado (R$):")
LEIA(PR)
PRID<-CAIXA*0.8
TOT_CAIXA<-QTD*PRSE(TOT_CAIXA>PRID) ENTAO
ESCREVAL("Melhor opção é à prazo")
APRAZO<-TOT_CAIXA*1.10
PARCELA<-PRAZO/3
ESCREVAL("Total a ser pago será:",APRAZO, "reais.")
ESCREVAL("Em três parcelas de:",PARCELA, " reais.")
SENAO
SE(PRID>TOT_CAIXA) ENTAO
DESCONTO<-(TOT_CAIXA-(TOT_CAIXA*0.05))ESCREVAL("Melhor Opção é à vista")
ESCREVAL("Pagamento total de",DESCONTO, " reais.")
FIMSE
FIMSE
ATE(CAIXA<0)OU(QTD<0)OU(PR<0)
FIMALGORITMO
tracking img