Resumo de algoritimo

Disponível somente no TrabalhosFeitos
  • Páginas : 2 (430 palavras )
  • Download(s) : 0
  • Publicado : 16 de abril de 2013
Ler documento completo
Amostra do texto
|Trabalho de Algoritmos |
|NOME:|RA: |
|CURSO: Engenharia (ciclo básico)|SÉRIE 1 |
|DISCIPLINA: Algoritmos |DATA: |

1)Chapeuzinho Vermelho ao entrar na floresta, perdeu a noção dos dias da semana. A Raposa e o Lobo Mau eram duas estranhas criaturas que freqüentavam a floresta. A Raposa mentia às segundas, terças equartas-feiras, e falava a verdade nos outros dias da semana. O Lobo Mau mentia às quintas, sextas e sábados, mas falava a verdade nos outros dias da semana. (Objetivo da Questão : Raciocínio Lógico)Numa ocasião Chapeuzinho Vermelho encontrou a Raposa sozinha. Ela fez as seguintes afirmações:

- Eu menti ontem
- Eu mentirei daqui a 3 dias.


Qual era o dia da semana ?
Segunda
R:__________________________________________________

2) Verifique o algoritmo abaixo sabendo que a variável n vai receber o seu número de chamada na digitação dos dados, mostre ao final o valor de X.(Objetivo da Questão : Teste de Mesa)

Algoritmo Trabalho_Muito_Facil
Var
N, X : Inteiro
Início
Escreva(“Digite um número :”)
Leia(N)
X:=(N*3)+1
Se ((X % 2)==0) entãoX:=X+N
Senão
X:=X-N
FimSe
Escreva(“O Valor de X é : “, X)
FimAlgoritmo

Valor de X : ________________________________

3) Vamos imaginar duas variáveis, uma chamada sexoque vai conter ‘M’ ou ‘F’ de acordo com seu sexo e outra variável idade que ira conter sua idade. Baseado nisso qual seria a mensagem apresentada no final da execução desse algoritmo : (Objetivo da...
tracking img