Respostas algoritimos

Disponível somente no TrabalhosFeitos
  • Páginas : 4 (788 palavras )
  • Download(s) : 0
  • Publicado : 11 de outubro de 2011
Ler documento completo
Amostra do texto
RESPOSTAS ALGORITIMOS LISTA 1
1) Dê o resultado e o tipo de cada uma das seguintes expressões:
(a) 5 * 2 + 3
r) 13 = Inteiro
(b) 6 + 19-0,3
r) 24,7 = real
(c) 3 * 5 + 1
r) 16 = Inteiro(d) 1 /4 + 2
r) 2,25 = real
(e) 29,0 / 7 + 4
r) 8,1428 = real
(f)3 / 6,0 -7
r) -6,5 = real
(g) 16 * 6 -3 * 2
r) 90 = Inteiro
(h) 3 + 2 * (18 -4 * 2)
r) 23 = Inteiro
(i) -2 * 3
r) -6= Inteiro
(j) 2 *2 * 3
r) 12 = Inteiro
(k) (28 + 3 * 4) / 4 * 8 -30 / 6
r) 75 = Inteiro

2) Qual o resultado das expressões lógicas abaixo, sabendo-se que os valores de A e B são,respectivamente, VERDADEIRO e FALSO?
a) not A and B or A and not B
Verdadeiro
b) not (not (A or B) and (A or B))
Verdadeira
c) A or B and not A or not B
Falso
d) (A or B) and (not A or not B)
Falso3) Escreva um algoritmo, em português estruturado (Portugol), que leia um número e exiba
seu sucessor.
var
num:inteiro
inicio
escreva ("Digite o Número:")
leia (num)
escreva ("O Sucessordo Número é:",num+1)
fimalgoritmo

4) Escreva um algoritmo, em português estruturado (Portugol), que leia dois números inteiros, x e y, e imprima o quociente e o resto da divisão inteira entreeles.
var
num1,num2,quociente,resto:inteiro
inicio
escreva ("Digite o 1º Número:")
leia (num1)
escreva ("Digite o 2º Número:")
leia (num2)
quociente:=num1\num2
resto:=num1 mod num2
escreval ("Oquociente é:",quociente)
escreval ("O resto é:",resto)
fimalgoritmo
5) Escreva um algoritmo, em português estruturado (Portugol), que informe se um dado ano é ou não bissexto. Observação: um ano ébissexto se ele for divisível por 400 ou se ele for divisível por 4 e não por 100.
var
ano:inteiro
inicio
escreva ("Digite o ano:")
leia (ano)
se (ano mod 400 = 0) entao
escreva ("O ano ébissexto")
senao
se (ano mod 4 = 0) e (ano mod 100 <> 0)entao
escreva ("O ano é bissexto")
senao
escreva ("O ano não é bissexto")
fimse
fimse
fimalgoritmo
6) Escreva um algoritmo, que...
tracking img