Normas

Disponível somente no TrabalhosFeitos
  • Páginas : 3 (552 palavras )
  • Download(s) : 0
  • Publicado : 12 de maio de 2012
Ler documento completo
Amostra do texto
Curso: SISTEMAS DE INFORMAÇÃO
Disciplina-Turma: FUNDAMENTOS DE PROGRAMAÇÃO 1
Professor(a): ALAYNE DUARTE
Aluno(a):

Valor da avaliação: 1 PONTO
( X ) AV1 ( ) AV2 ( ) AVS ( )2ªCh. AVS
Data:06/09/2011
Matrícula:

Atividade Individual, discursiva e manuscrita.
Data para entrega: 21/09/2011 – Início da Aula.

Rubrica do coordenador:

1º Instrumento Componente da 1ª Avaliação

Nota edata da entrega da avaliação:

QUESTÃO 1
0,1PONTO
Determine se são válidos ou inválidos os nomes de variáveis a seguir. No caso de nomes inválidos, justifique sua resposta.
i.
primeiraNota
ii.p___________
iii.
_rimeiraNota
iv.
Primeira Nota
v.
1NotaQualquer
QUESTÃO 2
Escreva as expressões a seguir em pseudo-código.
Observação: não desenvolva ou simplifique as expressões.
a)0,1PONTO

x2  2x  1
x 1
b)

x

1
x y
1
1
yz

QUESTÃO 3
0,1PONTO
O programa a seguir deveria determinar se um número inteiro digitado pelo usuário está fora do intervalocompreendido
entre os números cinco e dez. O programa, no entanto, não apresentou os resultados esperados. Aponte o erro cometido
pelo programador.
inicio
leia (a)
se (a10) então
escreva(“Não pertenceao intervalo”)
senão
escreva(“Pertence ao intervalo”)
fim se
fim
QUESTÃO 4
0,1PONTO
O que será impresso pelo programa a seguir? Suponha que os números digitados pelo usuário são: 6, 4 e 2, nestaordem.
Inicio
leia (a)
leia (b)
leia (c)
se (a>b) então
b←b+a
a←b–a
b←b–a

fim se
se (b>c) então
c←c+b
b←c–b
c←c–b
fim se
se (a>b) então
b←b+a
a←b-a
b←b-a
fim se
escreva (a, “”, b, “ ”, c)
fim
QUESTÃO 5
0,1PONTO
Qual das expressões abaixo representa a condição a seguir. “O aluno será aprovado caso atenda dois critérios: média final
maior ou igual a 5.0 e menor ou igual a10.0 e número de presenças maior do que 75% das aulas.”
A)
B)
C)
D)
E)

(media >= 5.0) e (media = 0.75 * aulas)
(media >= 5.0) e (media = 0.75 * aulas)
(media >= 5.0) e (media 0.75 *...
tracking img