Nenhum

Disponível somente no TrabalhosFeitos
  • Páginas : 3 (587 palavras )
  • Download(s) : 0
  • Publicado : 5 de outubro de 2012
Ler documento completo
Amostra do texto
A tomada de decisão simples utiliza a instrução
se

(expressão-lógica)

entao



Fim se
Nesta instrução, se a expressão lógica for verdadeira, será executada a sequência decomandos.Caso a expressão lógica não seja verdadeira não será executada a seqüênciade comandos.
Exemplo 1 – Ler a média de um aluno e exibir uma mensagem informando se o mesmo está aprovado.
algoritmo"Verifica Aprovacao"
var
media: real
inicio
escreva l ("Digite a média do aluno")leia (media)
se
(media >=6)
entao
escreva ("Parabéns!!!! Você está aprovado.")
fim se fim algoritmo
Observe quesomente será exibida a mensagem
“Parabéns!!!! Você está aprovado."
Se a média for maior ou igual a 6.
1.2 Estrutura Condicional Composta
A tomada de decisão composta utiliza a instrução:
se(expressão-lógica)

entao


senao


Fim se
Nesta instrução, se a expressão lógica for verdadeira, será executada a
seqüência-de- comandos 1
. Caso a expressão lógica não seja verdadeiraserá executada a
seqüência- de-comandos 2
.



Exemplo 2 – Ler a média de um aluno e escrever se ele está aprovado ou reprovado.
algoritmo
"Verifica Aprovacao"
var
media: real
inicioescreva l ("Digite a média do aluno")leia (media)
se
(media >=6)
entao
escreva l ("Parabéns!!!! Você está aprovado.")
senao
escreva l ("Infelizmente você está reprovado!!!")
fim se fimalgoritmo
Observe que somente será escrito
"Parabéns!!!! Você está aprovado."
se a média for maior ou igual a 6. Se a média for menor que 6, não será escrita a referida mensagem,mas sim,
"Infelizmentevocê está reprovado!!!".

1.2 Estruturas Condicionais Encadeadas
Existem casos em que é necessário fazer algumas verificações sucessivas antes de executar uma seqüência de comandos. Neste casoutiliza-se estruturas condicionais encadeadas ou aninhadas.A tomada de decisão simples utiliza a instrução:
se

(expressão-lógica 1)

entao


Senão se

(expressão-lógica 2)

entao...
tracking img