Linguagem c

Disponível somente no TrabalhosFeitos
  • Páginas : 2 (490 palavras )
  • Download(s) : 0
  • Publicado : 12 de fevereiro de 2013
Ler documento completo
Amostra do texto
17)Dados a descrição do produto, a quantidade adquirida e o preço unitário, calcular e escrever o total (total = quantidade adquirida * preço unitário), o desconto e o total a pagar(total a pagar =total -desconto) sabendo-se que:

se quantidade <= 5 o desc será de 2%
se quantidade > 5 e <=10 o desc será de 3%
se quantidade >10 o desc será de 5%
ALGORÍTIMO
// Seção deDeclarações
var

produto:caracter
quantidade:inteiro
preco,total,desc_menor_5,desc_menor_10,desc_maior_10:real

inicio
// Seção de Comandos

desc_menor_5 <- 0.98
desc_menor_10 <- 0.97desc_maior_10 <- 0.95

escreval("Nome do Produto:")
leia(produto)

escreval("Quantidade :")
leia(quantidade)

escreval("Preco Unitario:")leia(preco)

total <- quantidade * preco

// Calculando total a pagar
se (quantidade <= 5) entao
total <- total * desc_menor_5
fimse

// Calculando total a pagarse (quantidade > 5) e (quantidade <= 10) entao
total <- total * desc_menor_10
fimse

// Calculando total a pagar

se(quantidade > 10) entaototal <- total * desc_maior_10
fimse

escreval("Produto : ",produto)
escreval("Preco : ",preco)
escreval("Total : ",total)

fimalgoritmo

PROGRAMA EM C#include <string.h>
#include <stdlib.h>
#include <conio.h>
#include <math.h>
#include <stdio.h>
int main()
{
char produto;
int quantidade;
floatpreco,total,desc_menor_5,desc_menor_10,desc_maior_10;

total = quantidade * preco;
desc_menor_5 = 0.98;
desc_menor_10 = 0.97;
desc_maior_10 = 0.95;printf("Nome do Produto:");
scanf("%c", &produto);

printf("Quantidade :");
scanf("%i", &quantidade);

printf("Preco Unitario:");
scanf("%f", &preco);...
tracking img