Linguagem de programacao

Disponível somente no TrabalhosFeitos
  • Páginas : 2 (464 palavras )
  • Download(s) : 0
  • Publicado : 24 de outubro de 2012
Ler documento completo
Amostra do texto
algoritmo “CARANGO VELHO”
// Função : A concessionária de veículos CARANGO VELHO está vendendo os seus veículos com desconto. Faça um algoritmo que calcule e exiba o valor do desconto e o valor aser pago pelo cliente de vários carros. O desconto
deverá ser calculado de acordo com o ano do veículo. Até 2000 – 12% e acima de 2000 – 7%. O sistema deverá perguntar se deseja continuar calculandodesconto até que a resposta seja: \u201c(N) Não\u201d . Informar total de carros com
// ano até 2000 e total geral.
// Autor : JonasBios
// Data : 12/04/2012
// Seção de Declarações
var
programa,opc: caractere
ano, total, total2000: inteiro
valor, valorFinal, desconto: real
inicio
// Seção de Comandos
programa <- “S”
enquanto programa <> “N” faca
limpatela
escreva(“Digite ovalor do carro: “)
leia(valor)
escreva(“Digite o ano do carro: “)
leia(ano)
se ano <= 2000 entao
desconto <- 0.12
total2000 <- total2000 + 1
total <- total + 1
senao
desconto <-0.07
total <- total + 1
fimse
desconto <- desconto * valor
valorFinal <- valor – desconto
escreval(“O valor do carro com desconto é de: “,valorFinal)
escreval(“”)
escreva(“Desejacontinuar calculando? (S) Sim – (N) Não – “)
leia(opc)
escolha opc
caso “S”
programa <- “S”
caso “N”
programa <- “N”
outrocaso
programa <- “S”
limpatela
escreval(“As opções disponíveissão apenas S ou N!!!”)
leia(opc)
fimescolha
fimenquanto
escreval(“Foram calculados”,total2000,” carro(s) com ano até 2000″)
escreval(“Total geral: “,total)
fimalgoritmo
 
algoritmo “semnome”// Função : 8. A concessionária de veículos “CARANGO VELHO” está vendendo os seus veículos com desconto. Faça um
//algoritmo que calcule e exiba o valor do desconto e o valor a ser pago pelo clientede vários carros. O desconto
//deverá ser calculado de acordo com o ano do veículo. Até 2000 – 12% e acima de 2000 – 7%. O sistema deverá
//perguntar se deseja continuar calculando desconto até...
tracking img