Informatica

Disponível somente no TrabalhosFeitos
  • Páginas : 2 (324 palavras )
  • Download(s) : 0
  • Publicado : 3 de outubro de 2012
Ler documento completo
Amostra do texto
CURSO: Análise e desenvolvimento de sistemas

Faça um algoritmo em portugol que mostre as 4 opções de tabuada em um menu:
1. Tabuada de Soma
2. Tabuada de Subtração
3. Tabuadade Multiplicação
4. Tabuada de Divisão
Com as seguintes condições:
* O algoritmo só finaliza quando o usuário digita 0;
* Se o usuário digitar qualquer opção diferente das opções databuada, o algoritmo deve informar que a opção é inválida;
* O algoritmo deve mostrar a tabuada que o usuário escolher (soma, subtração, multiplicação ou divisão) de qualquer número que eleescolher.
* O algoritmo não deve dar erro, por exemplo: nenhum número pode ser dividido por zero.

algoritmo "Tabuada com Menu de Opções"
// Função :
// Autor : Andre Leandro
// Data : 03/10/2012
//Seção de Declarações
var
n,i,final: inteiro
opcao: real

inicio
escreval("Escolha umas das Tabuadas!")
escreval("1. Tabuada de Soma")
escreval("2. Tabuada de Subtração")
escreval("3.Tabuada de Multiplicação")
escreval("4. Tabuada de Divisão")
escreval("")
escreval("Digite a opção desejada!")
leia(opcao)
escolha opcaocaso 1
escreval("")
escreval("Você escolheu a opção: 1. Tabuada de Soma")
escreval("digite um número")leia(n)
para i<-1 ate 10 faca
escreval (n, "+", i,"=", n+i)
fimpara
caso 2escreval("Você escolheu a opção: 2. Tabuada de Subtração")
escreval("digite um número")
leia(n)
para i<-1ate 10 faca
escreval(n, "-", i,"=", n-i)
fimpara
caso 3
escreval("Você escolheu a opção: 3....
tracking img