Exercicios prontos

Disponível somente no TrabalhosFeitos
  • Páginas : 2 (373 palavras )
  • Download(s) : 0
  • Publicado : 10 de setembro de 2012
Ler documento completo
Amostra do texto
1 – Crie um algoritmo que declare 3 variáveis inteiras e atribua os valores 1, 2 e 3 a elas; 3 variáveis caracteres e atribua a elas as letras a, b e c; finalmente mostre todos os valores.Inicio //começo do algoritmo
Inteiro: x,y,z;
Caracter: d,e,f; // declaração de variável
x1;
y2;
z3;
da;
eb;
fc:
escreva:( x,y,z,d,e,f);
fim algoritmo

2 – Escreva um algoritmo quesolicite 3 números em ponto flutuante e mostre a média aritmética.

inicio// começo do algoritmo
real: N1, N2, N3, MA; //declaração de variavel
leia(N1,N2,N3); //entrada de dados
MA(N1+N2+N3)/3;//processamento de dados
escreva(MA); //saída de dados
fim//termino do algoritmo

3 – Construa um algoritmo que calcule o salário de um empregado baseado no numero de horas que eletrabalhou, e noseu salário por hora, ao final mostre o salário.
inicio
real salário, salário hora;
inteiro: horas trabalhadas;
salário hora12.00
leia horas trabalhadas;
saláriosalario hora*horastrabalhadas;
escreva salário;
fim algoritimo

4 – Construa um algoritmo que calcule a média das notas 1º bimestre e 2º bimestre de um aluno qualquer, mostre a média obtida.

Inicio //começo doalgoritmo
real: B1, B2, MA; //declaração de variavel
leia(B1, B2); //entrada de dados
MA(B1+B2)/2; // processamento
escreva(MA); //saída de dados
fim algoritmo //termino doalgoritmo

5 – Crie um algoritmo para calcular a média ponderada de um aluno respeitando os seguintes pesosconsecutivos 2, 3 e 5. São dados o RA do aluno e suas três notas. No final, o algoritmodeverá escrever o RA do aluno e sua média.

Inicio //começo do algoritimo
Real n1,n2,n3,Ra,m1,m2,m3,MF // declaração de variavel
Leia Ra //entrada de dados
Leia n1,n2,n3 // entrada de dadosM1n1*2 //processamento
M2n2*3
M3n3*5
MFm1+m2+m3/10
Escreva Ra MF// saída de dados
Fim algoritimo

6 – Crie um algoritmo que leia dois números inteiros (A e B) e efetue as operações de adição,...
tracking img