Eletronica linear

Disponível somente no TrabalhosFeitos
  • Páginas : 2 (402 palavras )
  • Download(s) : 0
  • Publicado : 1 de julho de 2012
Ler documento completo
Amostra do texto
Questao 4
var
cont,cont_f,cont_m,cont_i, cont_ms,cont_fs,cont_ss:inteiro
idade,media,soma,porc:real
sexo,experiencia:caracter
inicio
repita
escreval("qual sua idade?")
leia (idade)escreval("qual seu sexo?")
escreval("F-feminino")
escreval("M-masculino")
leia (sexo)
escreval("possui experiencia?")
escreval("S-sim")
escreval("N-nao")leia(experiencia)
se (sexo="F")entao
cont_f<-cont_f+1
senao
se(sexo="M")e(experiencia="s")entao
cont_ms<-cont_ms+1
soma<-soma+idademedia<-soma/cont_ms
senao
se(sexo="M")e(idade<21)e(experiencia="S")entao
cont_fs<-cont_fs+1
senao
Se(sexo="F")e(idade<21)e(experiencia="S")entaocont_fs<-cont_fs+1
senao
se(sexo="S")e(experiencia="S")entao
cont_ss<-cont_ss+1
soma<-soma+idademedia<-soma/cont_ss
fimse
fimse
fimse
fimse
fimse

ATE idade=0
porc<-porc*100/cont_i
escreval("o numero de candidatas é=",cont_f)escreval("o numero de candidatos é=",cont_m)
escreval("a media das idades dos homens que tem experiencia é=",media)
escreval("a porcentagem de homens com idade superior a 25 é=",porc)
escreval ("o numerode mulheres com experiencia=S e idade<21 é=",cont_fs)

// Seção de Comandos
fimalgoritmo

Pascal 4
var
cont,cont_f,cont_m,cont_i, cont_ms,cont_fs,cont_ss:integer;idade,media,soma,porc:real;
sexo,experiencia:string;
begin
repeat
writeln('qual sua idade?');
readln (idade);
writeln('qual seu sexo?');
writeln('F-feminino');
writeln('M-masculino');readln (sexo);
writeln('possui experiencia?');
writeln('S-sim');
writeln('N-nao');
readln(experiencia);
if (sexo='F')then begin
cont_f:=cont_f+1;...
tracking img