Dpp algoritmo

Disponível somente no TrabalhosFeitos
  • Páginas : 2 (470 palavras )
  • Download(s) : 0
  • Publicado : 15 de junho de 2012
Ler documento completo
Amostra do texto
Algoritmo 4
VAR real: mes [30] [66], x = 1, y = 1, maiorvalor = 0, menorvalor = 2000, media = 0;
Inicio
Para x =1 ate 66, passo 1
Para y =1 ate 30, passo 1
escreva “Informe o valorda cotação da moeda hoje” + y;
leia (mes [x] [y]);
se (mes [x] [y] > maiorvalor) entao
maiorvalor = mes [x] [y];
fimse;
se (mes [x] [y] < menorvalor)entao
menorvalor = mes [x] [y];
fimse;
media = media + mes [x] [y];
Proximo;
montante = media/30;
escreva “A média da moeda” +y “é” + montante;
escreva “O maior valor do mês“ +y “é” + maiorvalor;
escreva “O menor valor do mês” + y “é” + menorvalor;
Proximo;
Fim.

[pic]












VAR real: mes [30] [66], x = 1, y = 1, maiorvalor = 0,menorvalor = 2000, media = 0;
VAR natural: tecla = 0;

Inicio
Para x =1 ate 66, passo 1
Para y =1 ate 10, passo 1
escreva “Informe o valor da cotação da moeda hoje” + y;leia (mes [x] [y]);
se (mes [x] [y] > maiorvalor10) entao
maiorvalor10 = mes [x] [y];
fimse;
se (mes [x] [y] < menorvalor10) entao
menorvalor10 = mes [x] [y];fimse;
media10 = media10 + mes [x] [y];

Proximo;
Para y =11 ate 20, passo 1
escreva “Informe o valor da cotação da moeda hoje” + y;
leia (mes [x] [y]);se (mes [x] [y] > maiorvalor20) entao
maiorvalor20 = mes [x] [y];
fimse;
se (mes [x] [y] < menorvalor20) entao
menorvalor20 = mes [x] [y];
fimse;
media20 = media20 +mes [x] [y];
Proximo;

Para y =21 ate 30, passo 1
escreva “Informe o valor da cotação da moeda hoje” + y;
leia (mes [x] [y]);
se (mes [x] [y] > maiorvalor30)entao
maiorvalor30 = mes [x] [y];
fimse;
se (mes [x] [y] < menorvalor20) entao
menorvalor30 = mes [x] [y];
fimse;
media30 = media30 + mes [x] [y];
Proximo;...
tracking img