Conversor moedas

Disponível somente no TrabalhosFeitos
  • Páginas : 13 (3224 palavras )
  • Download(s) : 0
  • Publicado : 27 de setembro de 2011
Ler documento completo
Amostra do texto
Inicio

Real: resul,resul1,resul2,valor,mbase,dif1,dif,2,dif3;
Inteiro: opcao1,opcao2,opcao3,ocao4,login,senha;
Caractere: verdade,menu;

Inteiro: j[31];
Inteiro: i[6];

Real: soma, cotação[31][5], media, maior = 0, menor = 9999;
Soma = 0;

Faça
Inicio:
Escreva(“Login!”);
Escreva(“------\n\n”);
Escreva(“[1] Administrador\n”);
Escreva(“[2]Conversor”);Escreva(“Opção:”);
Leia(Login);

Se (login==1)
Inicio;
Escreva(“Digite a senha para acessar a área Administrador: ”);
Escreva(“Senha: ”);
Leia(Senha);
Escreva(“Moeda 1 - Real”);
Escreva(“Moeda 2 - Dólar Canadense”);
Escreva(“Moeda 3 - Euro”);
Escreva(“Moeda 4 - Dólar Turismo”);
Escreva(“Moeda 5 – Dólar Comercial”);
Fimse;se(senha==1234)
Incio;
Para j 0 ate30 passo 1 faça
Inicio
Para i 0 ate 5 passo 1 faça
Inicio
Escreva(“Digite a Cotação do mês para a moeda : ”,j+1,i+1);
Leia(Cotação[j][i]);
Soma=soma+cotação[j][i];
Media=soma/31;
Fim;
Fimpara;
Escreva(“Escolha a moeda Base: ”);Escreva(“1 – Real\n 2- Dólar Canadense\n 3- Euro\n\n”);
Escreva (“opção: ”);
Leia(opção1);
Fimpara;
Fimse;

Se(opcao1==1)
Inicio;
Escreva(“Você escolheu converter a moeda Real!”);
Mbase=1,0000;
Fimse;

Se(opcao1==2)
Inicio;
Escreva(“Você escolheu converter a moedaDólar Canadense”);
Mbase=1,7420;
Fimse;

Se(“opcao1==3”);
Inicio;
Escreva (“Você escolheu converter a moeda Euro: ”);
Mbase=2,3360;
Fimse;

Escreva(“Deseja converter para qual moeda?”);
Escreva(“1- Real \n 2-Dolar Canadense \n 3- Euro \n 4- Dólar americano \n ”);
Escreva(“Opção: ”);
Leia(opção2);Se (opção==1)
Inicio
Escreva(“Você deseja fazer conversão para reais!”);
Resul=((valor*mbase)/1,0000));
Escreva(“O resultado e: R$ ”,resul);
Maior=cotacao[0][0];
Menor=cotação[0][0];

Para j de 0 ate 30 passo 1 faça
para i de 0 ate 5 passo 1 faça
Inicio
Se(cotação[j][i])maior)Maior=cotação[j][i];
Fimse;
Fimse;
Fimpara;
Fimse;

Escreva (“\n A moeda dos valores da cotação Mensal e: R$\n”,(media(cotação[0][0]+cotação[1][0]+cotação[2][0]+cotação[3][0]+cotação[4][0]+
cotação[5][0]+cotação[6][0]+cotação[7][0]+cotação[8][0]+cotação[9][0]+cotação[10][0]+cotação[11][0]+cotação[12][0]+cotação[13][0]+cotação[14][0]+caotacao[15][0]+
cotação[16][0]+cotação[17][0]+cotação[18][0]+cotação[19][0]+cotação[20][0]+
cotação[21][0]+cotação[22][0]+cotação[23][0]+cotação[24][0]+cotação[25][0]+
cotação[26][0]+cotação[27][0]+cotação[28][0]+cotação[29][0]+cotação[30][0])/31));

Escreva(“O maior valor da cotação Mês ”,maior);Escreva(“-------------------------------------------------------------------------------------”);
Escreva(“O Menor valor da Cotação no Mês ”,menor);

Se(opco2==2);
Inicio;
Escreva (“Você Deseja fazer a conversão para Dólares Canadense!”);
Resul=(valor*mbase/1,7420);
Escreva(“\n\n O resultado e’: CDN$ ”,resul);

Maior=cotação[0][0];
Mnor= cotação[0][0];
Para j de 0 ate 30 passo 1 faça
Para i de 0ate 5 paso 1 faça
Inicio;
Se(cotação[j][i]maior)
Maior=cotação[j][i];
Fimpara;
Fimse;

Maior = cotação[0][0];
Menor = cotação[0][0];

Para j de 11 até 20 passo 1 faça
Para i de 0 até 5 passo 1 faça
Inicio:
Se(cotação[j][i] maior)...
tracking img