Analise e desenvolvimento de sistemas

Disponível somente no TrabalhosFeitos
  • Páginas : 2 (360 palavras )
  • Download(s) : 0
  • Publicado : 19 de abril de 2011
Ler documento completo
Amostra do texto
ANHANGUERA EDUCACIONAL
FACULDADE DE JOINVILLE – UNIDADE I

ATPS ALGORITMOS

JOINVILLE
ABRIL 2011

Passo 1
Descrição narrativa:
→ Ler as quatro moedas: Real (R$), Dolar Americano Turismo(US$), Dolar Canadense (CDN$) e Euro (€).
→ Calcular a conversão das moedas.
→ Mostrar o resultado das conversões.
Pseudo-código:

INICIO
real resul,resul1,resul2, valor, mbase,perc1,perc2,perc3;inteiro opcao1,opcao2;
caractere abertura;
escreva ("Escolha a moeda Base: ");
escreva ("1 – Real, 2 - Dolar Canadense, 3 – Euro, 4 - Dolar Americano");
escreva ("Opcao: ");
leia(opcao1);
se(opcao1==1)
escreva ("Voce escolheu converter a moeda Real!");
mbase (1.0000;
fimse

Se (opcao1==2)
escreva ("Voce escolheu converter a moeda Dolar Canadense!");
mbase (1.940;
fimsese(opcao1==3)
escreva ("Voce escolheu converter a moeda Euro!");
mbase(2.2600;
fimse

se(opcao1==4)
escreva ("Voce escolheu converter a moeda Dolar Americano!");
mbase(1.7300;fimse
escreva ("Digite o valor a converter: ");
leia(valor);
FIM

Fluxograma

[pic]

Passo 3

INICIO
Caracter , R$, US$, CDN$, €
escreva ("Deseja converter para qual moeda?");escreva ("1 – Real, 2 - Dolar Canadense, 3 – Euro, 4 - Dolar Americano Turismo");
escreva ("Opcao:");
leia(opcao2);

se(opcao2==1)
escreva ("Voce Deseja fazer a conversao paraReais!");
resul ((valor*mbase/1.0000);
escreva ("O Resultado e:"=resul);
fim se

se (opcao2==2)
escreva ("Voce Deseja fazer a conversao para Dolares Canadense!");resul((valor*mbase/1.7300);
escreva ("O Resultado e: CDN$"= resul);
fim se

se (opcao2==3)
escreva ("Voce Deseja fazer a conversao para Euros!");
resul((valor*mbase/2.2600);
escreva ("O Resultado e:E$ "= resul);
fim se

se(opcao2==4)
escreva("Voce Deseja fazer a conversao para Dolar Americano! ");
escreva("Esta opcao mostrara:");
escreva("A cotação em Dólar Americano...
tracking img