Algoritimos lista 1

Disponível somente no TrabalhosFeitos
  • Páginas : 2 (495 palavras )
  • Download(s) : 0
  • Publicado : 25 de maio de 2012
Ler documento completo
Amostra do texto
1. Ler dois números inteiros e imprimir a soma. Antes do resultado, deverá aparecer a mensagem: Soma.
inicio
inteiro: num1, num2, soma;
escreva(“entre com dois números: “);leia(num1, num2);
soma num1 + num2;
escreva(“soma: “, soma);
fim
2. Ler dois números inteiros e imprimir o produto.
inicio
inteiro: num1, num2, prod;
escreva(“entre com doisnúmeros: “);
leia(num1, num2);
prod num1 * num2;
escreva(“produto: “, prod);
fim
3. Ler um número real e imprimir a terça parte deste número.
inicio
real: num;escreva(“entre com um numero: “);
leia(num);
escreva(“a terca parte e: “, num/3);
fim
4. Entrar com dois números inteiros e imprimir a seguinte saída:
a. Dividendo:
b.Divisor:
c. Quociente:
d. Resto:
inicio
inteiro: quoc, rest, val1, val2;
escreva(“entre com o dividendo: “);
leia(val1);
escreva(“entre com o divisor: “);leia(val2);
quoc val1 div val2;
rest val1 mod val2;
escreva(“dividendo: “, val1);
escreva(“divisor: “, val2);
escreva(“quociente: “, quoc);escreva(“resto: “, rest);
fim
5. Ler um número e imprimir se ele é par ou impar.
inicio
inteiro num;
escreva(“digite um numero: “);
leia(num);
se (num mod 2 = 0)
inicioescreva(“par”);
fimse
senão
inicio
escreva(“impar”);
fimsenao
fim
6. Entrar com um numero e informar se ele é ou não divisível por 5.
inicio
inteiro: num;
escreva(“digite umnumero: “);
leia(num);
se (num mod 5 = 0)
inicio
escreva(“e divisível por 5”);
fimse
senão
inicio
escreva(“não e divisível por 5”);
fimsenao
fim
7. Entrar com um numero einformar se ele é divisível por 3 e por 7.
inicio
inteiro: num;
escreva(“digite um numero: “);
leia(num);
se (num mod 3 = 0 e num mod 7 = 0)
inicio
escreva(“divisível por...
tracking img