ALGORITMO

Páginas: 3 (598 palavras) Publicado: 17 de setembro de 2014
1ª Questão:

A Biblioteca da Escola realizou um levantamento do seu acervo referente aos livros. Assim sendo, confeccione um algoritmo que:

a- Leia um conjunto de dados contendo:
Titulo doLivro (Flag = "FIM")
Tipo do Livro (“R”, “F”, “S”) - com crítica
Quantidade do Acervo
Quantidade Ideal do Acervo

b- Calcule e exiba para cada livro a quantidade necessária para aquisição.Considere a não necessidade de aquisição para um determinado livro, quando a quantidade do acervo for maior ou igual a quantidade ideal.

c- Exiba no final o total de livros de cada tipo e o título dolivro mais prioritário para aquisição (desconsiderando empates).



GABARITO - 1ª Questão
Algoritmo
declare TITULO, TIPO, MAISPRIOR literal
declare ACERVO, IDEAL, NECES, TOTR, TOTS, TOTF,MAIOR numérico
MAIOR = 0
MAISPRIOR = "NENHUM TÍTULO"
TOTR = 0
TOTS = 0
TOTF = 0
Escreva "Informe Título do livro - FIM sai prg"
Leia TITULO
Enquanto TITULO "FIM"
RepitaLeia TIPO
Até TIPO em ["R", "F", "S"]
Escreva "Informe demais dados do Título"
Leia ACERVO, IDEAL
NECES = 0
Se ACERVO MAIOR então
MAIOR = NECES
MAISPRIOR =TITULO
FimSe
FimSe
Escreva "Necessita-se adquirir ", NECES, " desse ", TITULO
Caso TIPO de
"R" : TOTR = TOTR + 1
"F" : TOTF = TOTF + 1
"S" : TOTS = TOTS + 1
FimCasoEscreva "Informe Título do livro - FIM sai prg"
Leia TITULO
FimEnquanto
Escreva TOTR, TOTF, TOTS
Escreva "Título mais prioritário para aquisição ", MAISPRIOR
FimAlgoritmo


2ª Questão:O Departamento de Trânsito deseja apurar as infrações ocorridas no 4º trimestre de 2012 na cidade. Assim sendo, confeccionar um algoritmo que:

a. Leia um conjunto de dados contendo:
Nome doMotorista (Flag = “Fim”)
Pontos perdidos pelas Infrações anteriores
Quantidade de infrações cometidas no trimestre.

b. Para cada infração cometida, leia o código e o mês (numérico) com crítica....
Ler documento completo

Por favor, assinar para o acesso.

Estes textos também podem ser interessantes

  • Algoritmo
  • Algoritmo
  • Algoritmos
  • Algoritmo
  • Algoritmo
  • Algoritmo
  • Algoritmo
  • Algoritmos

Seja um membro do Trabalhos Feitos

CADASTRE-SE AGORA!