Tecnonogia e analize e desenvolvimento de sistemas

Disponível somente no TrabalhosFeitos
  • Páginas : 2 (339 palavras )
  • Download(s) : 0
  • Publicado : 3 de outubro de 2012
Ler documento completo
Amostra do texto
1. Elaborar um algoritmo para receber uma matriz 4 por 3 e multiplique os elementos da terceira coluna por uma constante X, que será lida, e exibir a matriz modificada.
algoritmo"Matriz 4 por 3"
// Função : Multiplicar os elementos da terceira coluna por uma constante X
// Autor : Marcos
// Data : 6/20/2012
// Seção de Declarações
var
Num :Vetor[1..4,1..3] de Real
I, J, X : Inteiro
inicio
Escreva("Entre com a Constante: ")
Leia(X)
Para I de 1 ate 4 passo 1 faca
Para J de 1 ate 3 passo 1 faca
Escreval("Notas naMatriz: ")
Leia(Num[I,J]) //entre com o valor das notas na Matriz
se 3 = J entao
Num[I,J]<-Num[I,J] * X
fimse
fimpara
fimpara
para I de 1 ate 4 passo 1 facaEscreval(Num[I,1],Num[I,2],Num[I,3])// Escreve o valor da Matriz
fimpara
fimalgoritmo

Elaborar um algoritmo para receber uma matriz 3 por 3 e multiplique os elementos daprimeira coluna por 2, da segunda coluna por 5 e da terceira coluna por 3, exibir a matriz modificada.

algoritmo "semnome"
// Função :Matriz 3 por 3
// Autor : Multiplicar oselementos da primeira coluna por 2, da segunda coluna
// por 5 e da terceira coluna por 3
// Data : 6/20/2012
// Seção de Declarações
var
Num : Vetor[1..3,1..3] de Real
I, J: Inteiro
inicio
Para I de 1 ate 3 passo 1 faca
Para J de 1 ate 3 passo 1 faca
Escreval("Notas na Matriz: ")
//entre com o valor das notas na Matriz
Leia(Num[I,J])
//Primeira coluna
se J = 1 entao
Num[I,J]<-Num[I,J] * 2
fimse
// Segunda coluna
se J = 2 entao
Num[I,J]<-Num[I,J] * 5
fimse
// Terceira coluna
se J = 3 entaoNum[I,J]<-Num[I,J] * 3
fimse
fimpara
fimpara
para I de 1 ate 3 passo 1 faca
// Escreve o valor da Matriz
Escreval(Num[I,1],Num[I,2],Num[I,3])
fimpara
fimalgoritmo
tracking img