Portifolio 1 semestre analise e desenvolvimento de sistemas

Disponível somente no TrabalhosFeitos
  • Páginas : 5 (1132 palavras )
  • Download(s) : 0
  • Publicado : 13 de junho de 2012
Ler documento completo
Amostra do texto
SISTEMA DE ENSINO PRESENCIAL CONECTADO CURSO SUPERIOR DE TECNOLOGIA EM ANÁLISE E DESENVOLVIMENTO DE SISTEMAS.

NOME DO(S) AUTOR(ES): EDERSON CARLOS ALVES GOMES
JOÃO PAULO TOPAN JUNQUEIRA
ROBERTO CERANTO

TÍTULO DO TRABALHO: PRODUÇÃO TEXTUAL INTERDISCIPLINAR – EM GRUPO

NOME DO(S) AUTOR(ES): EDERSON CARLOS ALVES GOMES
JOÃO PAULO TOPAN JUNQUEIRA
ROBERTO CERANTO

TÍTULO DOTRABALHO: PRODUÇÃO TEXTUAL INTERDISCIPLINAR – EM GRUPO

Trabalho apresentado ao Curso Superior de Tecnologia em Análise e Desenvolvimento de Sistemas da Unopar – Universidade Norte do Paraná, para a disciplina Interdisciplinar.
Professores: Denise Dias; Eliane Araman; Éverson Morais; José R. Passini e Veronice de Freitas.

SUMÁRIO

1– INTRODUÇÃO
2 – DESENVOLVIMENTO
3- CONSIDERAÇÕES FINAIS
4 - REFERÊNCIAS



1 – INTRODUÇÃO
PARTE I
Produção Textual em Grupo – ADS
PARTE II
Traduzir para a linguagem lógica algum conceito de Fundamentos da Administração da Informação.

2 – DESENVOLVIMENTO
PARTE I
Produção Textual em grupo – ADS
Desenvolver os quatro primeiros exercícios utilizando o visualg. O quinto exercíciopode ser desenvolvido de forma integral ou através da representação de um código com a documentação de seu funcionamento (o programa deverá ser comentado para que seja possível analisar a forma como foi realizada a conversão).

1) Escreva o pseudocódigo equivalente ao fluxograma abaixo
Símbolos: Leia, Escreva, Processamento

algoritmo "calcular o consumo"
// Função : calcular o consumo
//Autor : Ederson; João Paulo, Roberto
// Data : 2/6/2011
// Seção de Declarações
var
dist_perc, comb_gasto, cm : real

inicio
// entrada de dados .............
escreval ("Entre com o valor da distancia percorrida")
leia (dist_perc)
escreval ("Qual a quantidade de combustivel gasto?")
leia (comb_gasto)

// processamento ...............
cm <- dist_perc / comb_gasto

// saídaescreval("Consumo médio =", cm , " Km/l")
fimalgoritmo

Resultado: Entre com o valor da distancia percorrida
20
Qual a quantidade de combustivel gasto?
10
Consumo médio = 2 Km/l

*** Fim da execução.
*** Feche esta janela para retornar ao Visualg.

2) Crie um algoritmo que receba pelo teclado o nome de um Funcionário e seu salário bruto. Se o salário for acima de R$ 1.000,00,calcule 11% de desconto de INSS; se não, calcule 9%. Ao final, exiba o nome do funcionário, o salário bruto e o salário com o desconto de INSS.
algoritmo "desconto INSS"
// Função :desconto INSS
// Autor : : Ederson; João Paulo, Roberto
// Data : 2/6/2011
// Seção de Declarações
var
nome : literal
sal_bruto, sal_desc : real
inicio
// entrada de dados
escreval ("Entre com o nomedo Funcionário")
leia (nome)
escreval ("Digite o valor do salario bruto")
leia (sal_bruto)

// processamento

se (sal_bruto > 1000) entao
sal_desc <- sal_bruto*0.11

senao
fimse
se (sal_bruto < 1000) entao
sal_desc <- sal_bruto*0.09
fimse
// saida

escreval ("O funcionario ", nome," tem como salario bruto", sal_bruto, " e com desconto do INSS", sal_desc)fimalgoritmo

Resultado:
1 - Entre com o nome do Funcionário
Ana
Digite o valor do salario bruto
900
O funcionario Ana tem como salario bruto 900 e com desconto do INSS 81

*** Fim da execução.
*** Feche esta janela para retornar ao Visualg.
2- Entre com o nome do Funcionário
Joao
Digite o valor do salario bruto
2000
O funcionario Joao tem como salario bruto 2000 e com desconto doINSS 220

*** Fim da execução.
*** Feche esta janela para retornar ao Visualg.

3) Crie um algoritmo em que, dada a tabela a seguir, calcule o valor de desconto a ser concedido para um determinado cliente, de acordo com o valor da compra. O algoritmo deverá receber pelo teclado o nome do cliente e o valor total da compra.
Valor a compra | % de desconto |
Até R$ 1.000,00 | 5 |...
tracking img