Plt 193 exercicio resolvidos - pag 46 47 64

Disponível somente no TrabalhosFeitos
  • Páginas : 3 (567 palavras )
  • Download(s) : 0
  • Publicado : 27 de setembro de 2012
Ler documento completo
Amostra do texto
******************************************************************
*** RESOLUÇÃO DA LISTA DE EXERCÍCIOS CA_LISTA_EXERCÍCIO_2 ***
*** Construção de Algoritmos ***
******
******************************************************************

// Pág. 46 – Exerc. 2.4

algoritmo PesoIdeal;
inicio
real: h, pesoIdeal;
caracter: sexo;

repitaescreva("Informe seu sexo [M/F]:");
leia(sexo);
até ((sexo='M') ou (sexo='m') ou (sexo='F') ou (sexo='f'));

escreva("Informe sua altura: ");
leia(altura);

se ((sexo = 'M') ou (sexo = 'm'))então
pesoIdeal <- (72.7 * h) - 58;
senão
pesoIdeal <- (62.1 * h) - 44.7;
fimse;

escreva("Seu peso ideal é: ", pesoIdeal);
fim.

//Pág. 47. Exerc. 2.10

algoritmo IMC;inicio
real: peso, imc, altura;

leia(peso);
leia(altura);
imc <- peso / pot(altura,2);

se (imc<18.5) então
escreva("Abaixo do peso");
senão
se (imc<=25) entãoescreva("Peso Normal")
senão
se (imc<=30) então
escreva("Acima do peso");
senão
escreva("Obeso");
fimse;
fimse;
fimse;
fim.

//Pág. 62 – Exerc. 6

algoritmoComercianteMaluco;
inicio
real: valorPrestacao, novoValorPrestacao;

leia(valorPrestacao);

novoValorPrestacao <- valorPrestacao + valorPrestacao * 10%;
novoValorPrestacao <- novoValorPrestacao -novoValorPrestacao * 10%;

escreva("O valor da nova prestacao é: ", novoValorPrestacao);
escreva("O valor do prejuizo é: ", valorPrestacao - novoValorPrestacao);
fim.

//Pág. 64 – Exerc. 13algoritmo MMC;
inicio
inteiro: a, b;

leia(a, b);

se(a=b) então
escreva("O MMC é ", a);
senão
inicio
inteiro: i, j;
j <- 1;

enquanto ((a>1) ou (b>1))faça
enquanto ((a mod i = 0) ou (b mod i = 0)) faça
se (a mod i = 0) então
a <- a / i;
fimse;
se (b mod i = 0) então
b <- b / i;
fimse;
j <- j...
tracking img