Mikrotik

Disponível somente no TrabalhosFeitos
  • Páginas : 15 (3732 palavras )
  • Download(s) : 0
  • Publicado : 18 de outubro de 2012
Ler documento completo
Amostra do texto
Provedor de Internet e Serviços - (41) 3673-5879 Balance PCC para 3 links adsl com modem em bridge (2 links de 8mb, 1 link de 2mb).

Seu servidor deverá estar com a versão 3.24 ou superior do Mikrotik RouterOS e no mínimo 4 (quatro) placas de rede. A versão usada no exemplo abaixo foi a v4.5. Primeiro de tudo vamos dar nome as interfaces: ether1 = saida (Interface onde os link`s vão sair jábalanceados). ether2 = wlan1 (Interface onde sera ligado o link1 de 8mb) ether3 = wlan2 (Interface onde sera ligado o link2 de 8mb) ether4 = wlan3 (Interface onde sera ligado o link3 de 2mb) Eu usei os seguintes IP`s: Interface saida = 172.16.0.1/24 Interface wlan1 = 10.1.1.2/24 (IP no modem = 10.1.1.1) Interface wlan2 = 10.2.2.2/24 (IP no modem = 10.2.2.1) Interface wlan3 = 10.3.3.2/24 (IP no modem= 10.3.3.1) Obs.: Não é necessário definir os IP`s agora, pois o “script” irá definir no momento em que ele for “rodado”. Caso você for usar outros IP`s, os mesmos devem ser mudados no “script”. “Script” Primeira Parte (Define IP`s para as interfaces): /ip address add address=172.16.0.1/24 broadcast=172.16.0.255 comment="" disabled=no \ interface=saida network=172.16.0.0 add address=10.1.1.2/24broadcast=10.1.1.255 comment="" disabled=no \ interface=wlan1 network=10.1.1.0 add address=10.2.2.2/24 broadcast=10.2.2.255 comment="" disabled=no \ interface=wlan2 network=10.2.2.0

add address=10.3.3.2/24 broadcast=10.3.3.255 comment="" disabled=no \ interface=wlan3 network=10.3.3.0 Obs.: O que esta destacado deverá ser mudado, caso os IP`s que serão usados forem diferentes dos que eu usei.Caso você tenha definido os IP`s para as interfaces “manualmente” pelo WinBOX “pule” essa parte e vá diretamente para a Segunda Parte. Confirme pelo WinBox em IP => Address se tudo foi setado corretamente. Segunda Parte (Define servidores DNS): /ip dns set allow-remote-requests=yes cache-max-ttl=1w cache-size=10240KiB \ max-udp-packet-size=512 primary-dns=8.8.8.8 secondary-dns=\ 8.8.4.4 Obs.: Mude osDNS em destaque conforme os DNS da sua preferência. Terceira Parte (Criar os pppoe clientes para “discar” para os modem`s): /interface pppoe-client add ac-name="" add-default-route=no allow=pap,chap,mschap1,mschap2 comment=\ "===== Disca Link01 =====" dial-on-demand=no disabled=no interface=wlan1 \ max-mru=1480 max-mtu=1480 mrru=disabled name=pppoe-wlan1 password=xxxx \ profile=defaultservice-name="" use-peer-dns=no user=\ usuario@provedor.com.br add ac-name="" add-default-route=no allow=pap,chap,mschap1,mschap2 comment=\ "===== Disca Link02 =====" dial-on-demand=no disabled=no interface=wlan2 \ max-mru=1480 max-mtu=1480 mrru=disabled name=pppoe-wlan2 password=xxxx \ profile=default service-name="" use-peer-dns=no user=\ usuario@provedor.com.br add ac-name="" add-default-route=noallow=pap,chap,mschap1,mschap2 comment=\ "===== Disca Link03 =====" dial-on-demand=no disabled=no interface=wlan3 \ max-mru=1480 max-mtu=1480 mrru=disabled name=pppoe-wlan3 password=xxxx \ profile=default service-name="" use-peer-dns=no user=\ usuario@provedor.com.br Obs.: Mude xxxx para sua senha de autenticação junto ao seu provedor de acesso e usuario@provedor.com.br para seu login de autenticaçãojunto ao seu provedor de acesso. Quarta Parte (Regras Gerais para que o Balance funcione corretamente): /ip firewall nat add action=masquerade chain=srcnat comment=\ "===== Masquerade Interfaces =====" disabled=no out-interface=pppoe-wlan1 add action=masquerade chain=srcnat comment="" disabled=no out-interface=\ pppoe-wlan2 add action=masquerade chain=srcnat comment="" disabled=no out-interface=\pppoe-wlan3

/ip firewall mangle add action=accept chain=prerouting comment="FORA DO LOADBALACED" disabled=no \ dst-address-list=loopback in-interface=saida add action=mark-connection chain=input comment=\ "===== Make the packet leaves via same interface =====" disabled=no \ in-interface=pppoe-wlan1 new-connection-mark=wlan1_conn passthrough=yes add action=mark-routing chain=output comment=""...
tracking img