Html

Disponível somente no TrabalhosFeitos
  • Páginas : 4 (996 palavras )
  • Download(s) : 0
  • Publicado : 17 de abril de 2012
Ler documento completo
Amostra do texto
Estruturas de Seleção
Uma estrutura de seleção permite a escolha de um grupo de ações (comandos) a serem executadas quando uma ou mais condições, representadas por expressões lógicas, são ou nãosatisfeitas.

Estrutura de Seleção Simples
É utilizada para verificar se uma determinada condição é avaliada como verdadeira. Se for verdadeira, um conjunto de instruções (comandos) será executado.Exemplo pseudocódigo:
programa SELECAO_SIMPLES var a 0 , b 0 :inteiro início escreva "Digite o valor de a:" leia a escreva "Digite o valor de b:" leia b se (a > b) então escreva "a eh maior que b. a =", a fim se fim

OBS: A mensagem dentro do bloco de código "se" será impressa na tela se o valor da variável "a" for maior que o valor da variável "b". Exemplo Linguagem C:
#include #include voidmain (void) { int a=0,b=0; printf("Digite o valor de a: "); scanf("%d",&a); printf("Digite o valor de b: "); scanf("%d",&b); if(a > b) { printf("a eh maior que b. [a = %d]",a); } getch(); }

1 Estrutura de Seleção Composta
É utilizada para verificar se uma determina condição é avaliada como verdadeira. Se for verdadeira, um conjunto de instruções (comandos) será executado. Se for falsa,outro conjunto de instruções (comandos) será executado. Exemplo pseudocódigo:
programa SELECAO_COMPOSTA var a 0, b 0 : inteiro inicio escreva "Digite o valor de a:" leia a escreva "Digite o valor deb:" leia b se (a > b) então escreva "a eh maior que b. a = ", a senão escreva "b eh maior que a. b = ", b fim se fim

OBS: A mensagem dentro do bloco de código "se" só será impressa na tela se o valorda variável "a" for maior que o valor da variável "b". Caso contrário, a mensagem que está dentro do bloco de código "senão" será impressa na tela. Exemplo linguagem C
#include #include void main(void) { int a=0,b=0; printf("Digite o valor de a: "); scanf("%d",&a); printf("Digite o valor de b: "); scanf("%d",&b); if(a > b) { printf("a eh maior que b. [a = %d]",a); } else { printf("b eh...
tracking img