Dfdfffffdfdf

Disponível somente no TrabalhosFeitos
  • Páginas : 3 (660 palavras )
  • Download(s) : 0
  • Publicado : 26 de janeiro de 2013
Ler documento completo
Amostra do texto
algoritmo "media aluno"
// Função : media ponderada
// Autor : Gustavo Rodrigues Torre
// Data : 28/10/07
// Seção de Declarações
var
n1,n2,n3 : real
maior,menor,mp,nmaior1,nmaior2,nmaior3,nmenor1, nmenor2, nmenor3 : real
c, co_a : inteiro
inicio
// Seção de Comandos
menor <- 10
maior <- 0
repita
escreva("Digite o código do aluno: ")
leia(co_a)

escreva("Digite as notas")
leia (n1,n2,n3)

se (n1 > maior) entao
maior <- n1
fimse
se (n2 > maior) entao
maior <- n2
fimse
se (n3 > maior) entao
maior <- n3
fimse

se (n1 = maior) entaonmaior1 <- n2
nmaior2 <- n3
fimse

se (n2 = maior) entao
nmaior1 <- n1
nmaior2 <- n3
fimse

se (n3 = maior) entao
nmaior1 <- n1
nmaior2 <- n2
fimse

mp <- (maior * 4 +nmaior1 * 3 + nmaior2 * 3) / 10

escreval
se (mp>=5) entao
escreval("Aluno aprovado")
senao
escreval("Aluno reprovado")
fimse

escreval("As notas foram",n1,",",n2,",",n3)
escreval("O códigodo aluno eh",co_a)
escreval("A media ponderada foi",mp)
ate (co_a<1)
fimalgoritmo

algoritmo "semnome"
// Função :
// Autor :
// Data : 27/04/2012
// Seção de Declarações
varvotos,t1,t2,t3,t4, nulo, branco : inteiro
inicio
repita
Escreval (" <><><><>Escolha o seu Candidato<><><><>")
Escreval ("Digite 1º para votar no CandidatoNumero 1")
Escreval ("Digite 2º para votar no Candidato Numero 2")
Escreval ("Digite 3º para votar no Candidato Numero 3")
Escreval ("Digite 4º para votar no Candidato Numero 4")
Escreval ("Digite 5ºpara votar em nulo")
Escreval ("Digite 6º para votar em branco")
Leia (votos)
Escolha votos
caso 1
t1 := t1 + 1
caso 2
t2 := t2 + 1
caso 3
t3 := t3 + 1
caso 4
t4 := t4 + 1
Caso 5
nulo :=nulo + 1
caso 6
branco := branco + 1
fimescolha
limpatela
ate votos = 0

escreval ("Candidato 1 obteve ", t1," votos.")
escreval ("Candidato 2 obteve ", t2," votos.")
escreval ("Candidato...
tracking img