Algortmo

Disponível somente no TrabalhosFeitos
  • Páginas : 3 (647 palavras )
  • Download(s) : 0
  • Publicado : 10 de julho de 2012
Ler documento completo
Amostra do texto
Algorítmo

01. “Os dados são representados pelas informações a serem tratadas (processadas)
por um computador. Essas informações estão caracterizadas por três tipos de dados, a
saber:”

(x) a)dados numéricos (inteiros e reais), dados caracteres e dados lógicos.
b) dados tipo data, dados caracteres e dados lógicos.
c) dados binários, dados literais e dados lógicos.
d) dados vetores(inteiros e reais), dados caracteres e dados booleanos.
e) dados matrizes, dados inteiros e dados lógicos.
02. Faça um algoritmo que receba dois números qualquer e exiba o resultado da sua
soma.

03.Faça um algoritmo que receba dois números e no final exiba a multiplicação, soma,
divisão e a subtração dos números lidos.

04. Supondo que o valor de entrada da variável “salario” seja 1000.00,qual será o
valor do “novo_salario”?
algoritmo "Reajusta_Salario"
var
novo_salario: real
salario: real
Inicio
leia(salario)
se (salario < 500) entao
novo_salario <- salario * 1.15
senaose (salario <= 1000) entao
novo_salario <- salario * 1.10
senao
novo_salario <- salario * 1.05
fimse
fimse
escreva(novo_salario)
fimalgoritmo

a) 1000.50
b) 1150.00
c) 1050.00(X)d) 1100.00
e) 1105.50

05. No final da execução do fragmento de código abaixo, qual é o valor de n1, n2 e n3?
var n1,n2: inteiro
n1 10
n2 30
n3 n1
n1 n2
n2 n3

06. Após execução doprograma o que será escrito?
algoritmo "SIMULADO"
var
CONTADOR : inteiro
FAT : inteiro
inicio
FAT <- 1
CONTADOR <- 1
enquanto (CONTADOR <=5) faca
FAT <- FAT * CONTADOR
CONTADOR <-CONTADOR + 1
fimenquanto
escreva(FAT)
fimalgoritmo

a) 0 b) 24 c) 36 (X) d) 120 e) 240

07. Desenvolva um algoritmo que leia o nome de um vendedor, o seu salário base e o
total de vendasefetuadas por ele no mês (em dinheiro). Sabendo que este vendedor
ganha 20% de comissão sobre suas vendas efetuadas, informar o seu nome, o salário
base e salário no final do mês.

08. Escrever um...
tracking img