Algoritmos

Disponível somente no TrabalhosFeitos
  • Páginas : 3 (689 palavras )
  • Download(s) : 0
  • Publicado : 23 de setembro de 2011
Ler documento completo
Amostra do texto
ETAPA 1
PASSO 1

Algoritmo em Descrição Narrativa

Algoritmo
Informe um Valor;
Leia um Valor para dólar;
Efetua conversão de dólar para reais, multiplicando valor de dólar pela cotação dodólar;
Informa o Valor da Variável total.

Algoritmo descrição pseudocódigo
Algoritmo
Real real1, dolar;
Escreva “informe um valor”;
Leia dólar;
real1 = dolar/0.619;
Escreva “O Valor em Reaise”;
Escreva total;
Fim Algoritmo

Algoritmo em Fluxograma
Inicio
Inicio

real1 = dolar/0.619
real1 = dolar/0.619

Total
Total

Fim
FimPASSO 2

Algoritmo em Pseudocódigo
Algoritmo
real dolar, euro, dolarc, reald, realeur, realdc ;
Escreva" Insira o valor em Dolar a ser convertido:";
Leia “dolar”;
Escreva "Insira ovalor em Euro a ser convertido:";
Leia “euro”;
Escreva "Insira o valor em Dolar canadense a ser convertido:";
Leia “dolarc”;
reald = dolar/0.619;
Escreva "O valor de Dolarpara reais e ", reald);
realeur = euro/0.608;
Escreva "O valor de Euro para reais e ", realeur);
realdc = dolardc/0.437;
Escreva "O valor de Dolar canadense para reais e ",realdc);
FimAlgorimo

Algoritmo em Fluxograma

Ler Dolar
Ler Dolar
Inicio
Inicio

dolar/0.619

dolar/0.619euro/0.608

euro/0.608

dolarc/0.437

dolarc/0.437

REAL

REAL

Fim
Fim

PASSO 3

Pseudocódigo

Algoritmo
real dolar, dolarc, euro, reald, realdc, eurors ;
caractere escolha;Escreva ”Informe qual a moeda para conversão”;
Escreva"1 – Dolar, 2 - Dolar Canadense, 3 - Euro ";
Leia”escolha”;
Se (escolha=1) então
Escreva ”informe o valor em dolar”;
Leia “dolar”;
reald=dolar/0. 619;
Escreva ”O valor em reais e”, reald;
FimSe
Se (escolha=2) então
Escreva ”Informe o valor em Dolar Canadense”;
Leia”dolarc”;
realdc= dolarc/0. 437;
Escreva ”O valor em reais é”,...
tracking img