Algoritmos

Disponível somente no TrabalhosFeitos
  • Páginas : 5 (1028 palavras )
  • Download(s) : 0
  • Publicado : 23 de março de 2013
Ler documento completo
Amostra do texto
13.1 Algoritmo do Triangulo
Faça um algoritmo para ler a base e a altura de um triângulo. Em seguida, escreva a área do mesmo.
Obs: Área = ( Base * Altura ) / 2
Em Algoritmo:
Algoritmo Triangulo
Variaveis:
base, altura, area : real;
Inicio
Leia(Base)
Leia(Altura)
Area ← (Base * Altura)/2
Escreva (Area)
Fim

13.2 Algoritmo Preco Automóvel
O preço de um automóvel écalculado pela soma do preço de fábrica com o preço dos impostos (45%
do preço de fábrica) e a percentagem do revendedor (28% do preço de fábrica). Faça um algoritmo
que leia o nome do automóvel e o preço de fábrica e imprima o nome do automóvel e o preço final.
Em Algoritmo:
Algoritmo automovel
Variaveis
Nome : cadeia
Precofabrica, Precofinal, Imposto : real
Inicio
Leia(Nome, Precofabrica)
Imposto ← Precofabrica * (0,45 + 0,28)
Precofinal ← Precofabrica + Imposto
Escreva (Nome, Precofinal)
Fim

13.3 Algoritmo Media Valor
Dado uma série de 20 valores reais, faça uma algoritmo que calcule e escreva a média aritmética
destes valores, entretanto se a média obtida for maior que 8 deverá ser atribuída 10 para a média.
R.
Algoritmo Serie
VariaveisContador: Inteiro
N,Soma, Media :Real
Inicio
Contador ← 0
Soma ← 0
Enquanto Contador < 20 faca
Leia (N)
Soma ← Soma + N
Contador ← Contador + 1
Fim Enquanto
Media ← Soma / 20
Se Media > 8 Entao
Media ← 10
Fim Se
Escreva (Media)
Fim

13.4 Algoritmo 3 Menores
Faça um algoritmo que leia 3 números inteiros e imprima o menordeles.
Em Algoritimo:
Algoritmo Menor
Variaveis
A, B, C, Menor : Inteiro
Inicio
Leia ( A,B,C)
Se (A < B) E (A <C) Entao
Menor ← A
Senao
Se B < C Entao
Menor ← B
Senao
Menor ← C
Fim se
Fim se
Escreva (Menor)
Fim

13.5 Algoritmo Media Maior que 4
Dado um conjunto de n registros cada registro contendo umvalor real, faça um algoritmo que calcule a média
dos valores maiores que 4.
Em Algoritmo:
Algoritmo Media
Variaveis
N, Conta, Maior4 : Inteiro
Soma, Media, Numero :Real
Inicio
Conta ← 1
Maior4 ← 0
Soma ← 0
Leia (N)
Enquanto Conta < N Faça
Leia (Numero)
Se Numero > 4 Entao
Soma ← Soma + Numero
Maior4 ← Maior4 + 1
Fim Se
Conta ←Conta + 1
Fim Enquanto
Media ← Soma / Maior4
Escreva (Media)
Fim

13.6 Algoritmo Salário
Uma empresa tem para um determinado funcionário uma ficha contendo o nome, número de horas trabalhadas eo n0 de dependentes de um funcionário.
Considerando que:
a) A empresa paga 12 reais por hora e 40 reais por dependentes.
Sobre o salário são feito descontos de 8,5% para o INSS e 5% para IR.Faça um algoritmo para ler o Nome, número de horas trabalhadas e número de dependentes de um funcionário.
Após a leitura, escreva qual o Nome, salário bruto, os valores descontados para cada tipo de imposto e finalmente qual o salário líquido do funcionário.
Em Algoritmo:
Algoritmo salario
variaveis
nome : cadeia
dependente : inteiro53
horas, salariol, salariob, DescontoI,DescontoR : real;
Inicio
Leia(nome,horas, dependente)
salariob ← (12 * horas) + (40 * dependente)
DescontoI ← (salariob*0,085)
DescontoR ← (salariob*0,05)
salariol ← (salariob - DescontoI, DescontoR)
Escreva(nome,salarioB, DescontoI, DescontoR, salarioL)
Fim

13.7 Algoritmo 50 Triangulos
1) Faça um algoritmo para ler base e altura de 50 triângulos e imprimir a sua área.
EmAlgoritmo:
Algoritmo Triangulo
Variaveis
Contador: Inteiro
Base, Haltura, Area :Real
Inicio
Contador ← 1
Enquanto Contador < 51 faca
Leia (Base
Leia (Haltura)
Area ← (Base * Haltura)/2
Escreva( Area)
Contador ← Contador + 1
Fim Enquanto
Fim

13.8 Algoritmo Media Menores
Dado um conjunto de 20 valores reais, faça um algoritmo que:
a) Imprima os...
tracking img