Algoritmos prontos

Disponível somente no TrabalhosFeitos
  • Páginas : 8 (2000 palavras )
  • Download(s) : 0
  • Publicado : 22 de abril de 2013
Ler documento completo
Amostra do texto
Copie aqui se achar melhor o nome do grupo

TRABALHO
ALGORITMO E PROGRAMAÇÃO
RA:6822483935

TRABALHO DE ALGORITMOS E PROGRAMAÇÃO


Algoritmo
"Exercício 1"

// Função : 1. Faça um algoritmo que receba dois números e exiba o resultado da sua soma.
// Autor :  grupo
// Seção de Declarações
var
s,n1,n2:inteiro
inicio
// Seção de Comandos
escreval("Digite Primeiro Numero:")leia(n1)
escreval("Digite Segundo Numero:") leia(n2)
s<-n1+n2
escreval("Resultado da SOMA ",s)
fimalgoritmo

algoritmo "Exercício2"

// Função : 2. Faça um algoritmo que receba dois números e ao final mostre a soma, subtração, multiplicação e a divisão dos números lidos.
,// Autor :  grupo
// Seção de Declarações
var
n1,n2:real
inicio
// Seção de Comandos
escreval("Digite PrimeiroNumero: ")
leia(n1)
escreval("Digite Segundo Numero: ")
leia(n2)
escreval("A soma e ",n1+n2)
escreval("A subtracao e ",n1-n2)
escreval("A multiplicacao e ",n1*n2)
se(n2=0.0)entao
escreva("Divisao: Infinito")
senao
escreval("A divisao é ",n1/n2)
fimalgoritmo

algoritmo "exercício 3"

// Função :  3. Escrever um algoritmo para determinar o consumo médio de um automóvel sendo fornecidaa distância total percorrida pelo
//automóvel e o total de combustível gasto.
// Autor : grupo
// Seção de Declarações
var
dis,cm,cg:real
//dis=distância, cg=combustível gasto, cm=consumo médio
inicio
// Seção de Comandos
escreval("Informe a distancia percorrida: ")
leia(dis)
escreval("informe o total de combustivel gasto em litros: ")
leia(cg)
escreval("O automóvel faz em media",dis/cg," km/l")
fimalgoritmo

algoritmo "Exercício 4"

// Função : 4. Escrever um algoritmo que leia o nome de um vendedor, o seu salário fixo e o
//total de vendas efetuadas por ele no mês (em dinheiro). Sabendo que este vendedor ganha 15%
//de comissão sobre suas vendas efetuadas, informar o seu nome, o salário fixo e salário no final do mês.
// Autor : grupo
// Seção de Declarações
varnome: literal
salfixo,totalvendas,salfinal:real
inicio
// Seção de Comandos
escreval("Digite o nome do funcionario: ")
leia(nome)
escreval("Informe o seu salario fixo: ")
leia(salfixo)
escreval("Informe o total de vendas em R$: ")
leia(totalvendas)
salfinal <- (0.15 * totalvendas) + salfixo
// Resultados
escreva("Funcionario: ",nome)
escreval("o salario fixo e: ",salfinal)escreval("o salario com comissao e: ",salfinal)
fimalgoritmo

algoritmo "Exercício 5"

// Função : 5. E
escrever um algoritmo que leia o nome de um aluno e as
//notas das três provas que ele obteve no semestre. No final informar o nome do aluno e a sua média (aritmética).
// Autor : grupo
// Seção de Declarações
var
media,nota:real
x:inteiro
nome:literal
//Define
nota<-0
inicio
//Seção de Comandos
escreval("Informe o nome do aluno: ")
leia(nome)
para x de 1 até 3
escreval("Informe suas notas: ")
media=nota+nota
x=x+1
fimpara
escreva("Aluno: ",nome)
escreva("Media: "media/3),
fimalgoritmo

algoritmo "Exercício 6"

// Função :  6. Ler dois valores para as variáveis A e B, e efetuar as trocas dos valores de forma que a variável
// A passe a possuir o valor davariável
// B e a variável B passe a possuir o valor da variável A. Apresentar os valores trocados.
// Autor : grupo
// Seção de Declarações
var
a,b,c:inteiro
inicio
// Seção de Comandos
escreval("Informe o valor de a: ")
leia(a)
escreval("Informe o valor de b: ")
leia(b)
c<-a
a<-b
b<-c
escreval("O novo valor de a e: ",a)
escreval("O novo valor de b e: ",b)
fimalgoritmoalgoritmo "Exercício7"

// Função :7. Ler uma temperatura em graus Celsius e apresentá-la convertida em graus Fahrenheit. A fórmula de conversão é:
//F=(9*C+160) / 5, sendo F a temperatura em Fahrenheit e C a temperatura em Celsius.
// Autor : grupo
// Seção de Declarações
var
c,f:real
inicio
// Seção de Comandos
escreval("informe a temperatura em graus C:")
leia(c)
f<-(9*c+160)/5...
tracking img