Algoritmo

Disponível somente no TrabalhosFeitos
  • Páginas : 2 (422 palavras )
  • Download(s) : 0
  • Publicado : 30 de março de 2013
Ler documento completo
Amostra do texto
Tipos de triângulos 

♦ O triângulo pode ser classificado segundo a medida do seu lado.

Triângulo escaleno: Todos os lados e ângulos são diferentes.

Triângulos isósceles: dois lados iguais eos ângulos opostos a esses lados iguais.

Triângulo equilátero: Todos os lados e ângulos iguais. Concluímos que seus ângulos serão de 60°. 

Condição de existência de um triângulo

Paraconstruir um triângulo não podemos utilizar qualquer medida, tem que seguir a condição de existência:
Para construir um triângulo é necessário que a medida de qualquer um dos lados seja menor que a soma dasmedidas dos outros dois e maior que o valor absoluto da diferença entre essas medidas.

| b - c | < a < b + c
| a - c | < b < a + c
| a - b | < c < a + b
Exemplo:

14 – 8< 10 < 14 + 10
14 – 10 < 8 < 14 + 10
10 – 8 < 14 < 10 + 8

Algoritmo que recebe 3 números inteiros positivos e diz se formam um triângulo equilátero, isósceles ou escaleno, ou senão formam triângulos.

inicio
inteiro : a, b, c;
escreva (“ Digite o primeiro nº : ”);
leia ( a );
escreva (“ Digite o segundo nº : ”);
leia ( b );
escreva (“ Digite o terceiro nº : ”);leia ( c );
se ( |b – c| < a < (b + c) ) então
se ( |a – c| < b < (a + c) ) então
se ( |b – a| < c < (b + a) ) então

se ( a = b = c ) então
escreva ( “ formamtriângulo equilátero”);
fimse

se ( a ≠ b ≠ c ) então
escreva (“ formam triângulo escaleno”);
fimse

se ( a = b ≠ c ) então
escreva (“ formam triângulo isósceles”);
fimse

se ( a ≠ b = c )então
escreva (“ formam triângulo isósceles”);
fimse

se ( a = c ≠ b ) então
escreva (“ formam triângulo isósceles”);
fimse

senão
escreva (“Não formam triângulos”);
fimse
senão
escreva(“Não formam triângulos”);
fimse
senão
escreva (“Não formam triângulos”);
fimse
fim

#include <stdio.h>
#include <math.h>
main() {
int a, b, c;
printf (“ \n Digite o primeiro...
tracking img