Algoritmo

Disponível somente no TrabalhosFeitos
  • Páginas : 5 (1220 palavras )
  • Download(s) : 0
  • Publicado : 19 de março de 2013
Ler documento completo
Amostra do texto
1. Faça um algoritmo que receba um número inteiro qualquer informado pelo usuário e escreva se este número é primo ou não.
Obs.: Para ser um número primo, este número tem ser divisível apenas por 1 e por ele mesmo.

algoritmo "Exe1"
var
num,i,cont:inteiro
inicio
escreva("Digite um número: ")
leia(num)
para i de 1 ate num faca
se (num mod i = 0) entao
cont<-cont +1
fimse
fimpara
se (cont <= 2)entao
escreva("O número ",num, " é um número primo.")
senao
escreva("O número ",num, " não é um número primo.")
fimse
fimalgoritmo

2. Faça um algoritmo que receba um número inteiro qualquer informado pelo usuário e escreva o fatorial deste número.
Obs.: O fatorial de um número é a multiplicação deste número pelo seusantecessores até 1.
Ex.: 4! = 4 x 3 x 2 x 1 = 24

algoritmo "Exe2"
var
num,i,fat:inteiro
inicio
fat<-1
escreva("Digite um número: ")
leia(num)
para i de num ate 1 passo -1 faca
fat<- fat * i
fimpara
escreva(num,"! = ",fat)
fimalgoritmo

3. Faça um algoritmo que receba um número inteiro informado pelo usuário em uma variável qualquer. Uma segunda variável recebera onúmero informado pelo usuário e multiplicará por 2. Em um laço de repetição, a primeira variável receberá incremento de 3 e a segunda variável receberá incremento de 2. O algoritmo deverá informar quantas vezes o laço de repetição irá rodar enquanto a primeira variável for menor ou igual a segunda variável.

algoritmo "Exe3"
var
a,b,cont:inteiro
inicio
escreva("Digite um número: ")leia(a)
b<-a * 2
enquanto (a <= b) faca
a<-a + 3
b<-b + 2
cont<-cont + 1
fimenquanto
escreva("O laço de repetição rodou",cont," vezes")
fimalgoritmo

4. Faça um algoritmo que receba o valor de um depósito em um fundo de rendimento, a taxa de juros fixa e o período de aplicação. Calcule e mostre o rendimento mensal desta aplicação conforme o períodoutilizando juros composto.

algoritmo "Exe4"
var
deposito,taxa,periodo,i:real
inicio
escreva("Depósito R$")
leia(deposito)
escreva("Taxa de juros: ")
leia(taxa)
escreva("Período da aplicação: ")
leia(periodo)
escreval("--------------------------------------------------------")
escreval("Aplicação inicial R$",deposito:1:2)
enquanto (i < período) facadeposito<-deposito * (1 + (taxa/100))
i<-i + 1
escreval(i,"º mês R$",deposito:1:2)
fimenquanto
fimalgoritmo

5. Faça um algoritmo que receba 10 número em um vetor de inteiros. Após receber os 10 números, ordenar estes números no vetor e escrevê-los em ordem crescente.

algoritmo "Exe5"
var
v1:vetor[1..10] de inteiro
i,j,aux:inteiro
inicio
para i de 1 ate 10 facaescreva("Digite um número: ")
leia(v1[i])
fimpara
para i de 1 ate 10 faca
para j de (i+1) ate 10 faca
se (v1[i] > v1[j]) entao
aux<-v1[i]
v1[i]<-v1[j]
v1[j]<-aux
fimse
fimpara
fimpara
para i de 1 ate 10 faca
escreva(v1[i])
fimpara
fimalgoritmo

6. Faça um algoritmo que armazene 20 números em umvetor. Após receber os 20 números escrever qual é o maior número e em qual posição se encontra e qual o menor número e sua posição.

algoritmo "Exe6"
var
v1:vetor[1..20] de inteiro
i,maior,menor,p_maior,p_menor:inteiro
inicio
para i de 1 ate 20 faca
escreva("Digite o ",i,"º número: ")
leia(v1[i])
fimpara
maior<-v1[1]
menor<-v1[1]
p_maior<-1p_menor<-1
para i de 1 ate 20 faca
se (v1[i] > maior) entao
maior<-v1[i]
p_maior<-i
fimse
se (v1[i] < menor) entao
menor<-v1[i]
p_menor<-i
fimse
fimpara
escreval("O menor número é o ",menor," e está na posição ",p_menor)
escreval("O maior número é o ",maior," e está na posição ",p_maior)
fimalgoritmo...
tracking img