Algoritmo c++

Disponível somente no TrabalhosFeitos
  • Páginas : 2 (255 palavras )
  • Download(s) : 0
  • Publicado : 21 de novembro de 2012
Ler documento completo
Amostra do texto
atividades aula 05

1. Fazer um algoritmo para entrar com um valor inteiro e dizer a qual mês do ano ele corresponde. Se o valor for maior que doze ou menor que um, diga que o valornão corresponde a nenhum mês. Exemplo: mês= 4 à “Mês de Abril”.


Algoritmo ``mês do ano´´
Var: jan, fev, mar, abr, mai, jun, jul, ago, set, out, nov, dez= caractere01, 02, 03, 04, 05, 06, 07, 08, 09, 10, 11, 12 = inteiro


Inicio
Escreva (`` mes de Jan´´)
Leia (01)
Leia (`` mês correspondente´´)
Escreva (`` mês de fev´´)Leia (02)
Leia (`` mês correspondente´´)
Escreva (`` mês de mar´´)
Leia (03)
Leia (`` mês correspondente´´)
Escreva ( ``mês de abr´´)
Leia(04)
Leia (`` mês correspondente´´)


Escreva (`` mês de mai´´)
Leia (05)
Leia (`` mês correspondente´´)
Escreva (`` mês de jun´´)
Leia (06)Leia (`` mês correspondente´´)
Escreva (`` mês de jul´´)
Leia (07)
Leia (`` mês correspondente´´)
Escreva (`` mês de ago´´)
Leia (08)
Leia (`` mêscorrespondente´´)
Escreva (`` mês de set´´)
Leia (09)
Leia (`` mês correspondente´´)
Escreva (``mês de out´´)
Leia (l0)
Leia (`` mês correspondente´´)Escreva (``mês de nov´´)
Leia (ll)
Leia (`` mês correspondente´´)
Escreva (`` mês de dez´´)
Leia (12)
Leia (`` mês correspondente´´)
Se < 01 entãoleia (`` mês não correspondente´´)
Se > 12 então
Leia (`` mês não correspondente´´)
Fimse
Fimse
Finalgoritimo














2.Elaborar um algoritmo para calcular e imprimir o índice de massa corporal de uma pessoa, utilizando a expressão: imc = peso/(altura *altura). em seguida exiba uma das seguintes mensagens.


[pic]...
tracking img