Algoritimo

Disponível somente no TrabalhosFeitos
  • Páginas : 7 (1680 palavras )
  • Download(s) : 0
  • Publicado : 11 de setembro de 2012
Ler documento completo
Amostra do texto
algoritmo "media_aluno"
// Função :
// Autor :
// Data : 17/11/2011
// Seção de Declarações
var
nome: caracter
nota1: real
nota2: real
nota3: real
media: real

inicio
// Seção de Comandos
escreva("Qual o Seu nome: ")
leia (nome)
limpatela
escreva("Digite primeira nota: ")
leia (nota1)
limpatela
escreva ("Digite segunda nota: ")
leia (nota2)
limpatela
escreva("Digite terceira nota: ")
leia (nota3)
limpatela
media <- (nota1+nota2+nota3)/3
se (media >= 6) entao
escreva (nome," Você esta APROVADO")
senao
escreva (nome," Você esta REPROVADO")
fimse

fimalgoritmo

_____________________________________________________________________

algoritmo "Senha_Banco"
// Função :
// Autor :
// Data : 07/11/2011
// Seção deDeclarações
var
Tecla: caracter
I: inteiro

inicio
// Seção de Comandos
I <- 0
repita
escreva ("Para retirar sua senha pressione a tecla! ")
leia (Tecla)
I <- I + 1
escreval ("SENHA ",I, " LIBERADA!")

__________________________________________________________________________

algoritmo "Tela_Login"
// Função :
// Autor :
// Data : 17/11/2011
// Seçãode Declarações
var
Nome: caracter
Senha: caracter
inicio
// Seção de Comandos
escreva ("Nome do usuario: ")
leia (Nome)
escreva ("Senha do usuario: ")
leia (Senha)
limpatela
se (Nome = "tecnico") e (Senha = "123*456") entao
escreva ("Seja bem Vindo!!!")
senao
escreva ("Senha INCORRETA!")
fimse
fimalgoritmo__________________________________________________________________________

algoritmo "numero_negativo"
// Função :
// Autor :
// Data : 21/11/2011
// Seção de Declarações
var
numero: inteiro
par,impar:real
dobro: real
inicio
// Seção de Comandos
escreval ("Qual o numero?")
leia (numero)
limpatela
se (numero < 0) entao
escreval ("numero negativo")
fimse
se (numero%2)=0 entao
escreval("NÚMERO PAR!")
escreval ("")
senao
escreval ("NÚMERO IMPAR")
escreval ("")
fimse
escreval ("O dobro de",numero," é",numero+numero)
fimalgoritmo
____________________________________________________________________

algoritmo "Temperatura"
// Função :
// Autor :
// Data : 21/11/2011
// Seção de Declarações
var
Temperatura: real

inicio
//Seção de Comandos
escreva ("Qual a temperatura? ")
leia (Temperatura)
limpatela
se (Temperatura >= 24) e (Temperatura <= 27) entao
escreva ("Temperatura ambiente!")
senao
escreva ("Temperatura não ambiente!")
fimse

fimalgoritmo
______________________________________________________________________

algoritmo "Salario_Funcionario"
// Função :
// Autor :
// Data :07/11/2011
// Seção de Declarações
var
Nome: caracter
HT, VH, NF, SB, SL: real

inicio
// Seção de Comandos
escreva ("Nome: ")
leia (Nome)
escreva ("Horas trabalhadas: ")
leia(HT)
escreva ("Valor hora: ")
leia (VH)
escreva ("Quantos filhos: ")
leia (NF)

SB <- (HT*VH)
SL <- (SB*0.94)
SL <- SL + (NF*23)
limpatela

escreva(Nome," Seu salario é: ", SL)fimalgoritmo
__________________________________________________________________________

algoritmo "Cadastro_Cliente"
// Função :
// Autor :
// Data : 07/11/2011
// Seção de Declarações
var
Nome: caracter
Idade, CPF: real
Renda: caracter
Serasa: caracter
Lserasa: logico
Lrenda: logico
inicio
// Seção de Comandos
escreva ("Nome: ")
leia (nome)
escreva ("Idade: ")
leia (Idade)enquanto (CPF <= 0) faca
escreva ("CPF: ")
leia (CPF)
fimenquanto
escreva ("Renda? (S/N)")
leia (renda)
se (renda= "S") ou (renda= "s") entao
Lrenda <- verdadeiro
fimse
escreva ("SERASA ? (S/N)")
leia (Serasa)
se (Serasa= "N" ) ou (Serasa= "n") entao
Lserasa <- falso
fimse
limpatela...
tracking img